Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
2,990 Views

ARM DS-5 device_browser.py failed

Hi, guys! 

I use the Quartus II 14.0 and ARM DS-5 Altera edition under CentOS 6.5 x64. I followed the ug_soc_eds.pdf guide to debug a baremetal program. 

During the configuration of the debugger, I found a mistake. When I click the "connect" button the error happend as the graph below. 

http://www.alteraforum.com/forum/attachment.php?attachmentid=9373&stc=1  

The error message was "The script file ( device_browser.py ) failed during execution:".  

I use jython executed the .py file in shell, it shows like below:$ jython device_browser.py  

Traceback (innermost last): 

File "device_browser.py", line 2, in ? 

ImportError: no module named arm_ds_launcher 

 

If you need more information, just tell me, thanks! 

 

 

I found something new, that maybe help to solve the problem. When I hook over the cursor  

under the error message, the program pops up an error tips like below: 

http://www.alteraforum.com/forum/attachment.php?attachmentid=9429&stc=1  

It said: 

Error, failed to load client library libjtag_client.so 

Please ensure that the environment variable QUARTUS_ROOTDIR is set to the path to 

the Altera quartus tools installation. 

because I execute the eclipse under the embedded_command_shell, so I checked the above  

environment variable, is echoed like below: 

$ echo $QUARTUS_ROOTDIR  

/usr/local/altera/14.0/quartus 

And I also checked the dynamic library, it shows like below: 

$ locate libjtag_client.so 

/usr/local/altera/13.1/quartus/linux/libjtag_client.so 

/usr/local/altera/13.1/quartus/linux64/libjtag_client.so 

/usr/local/altera/14.0/embedded/host_tools/mentor/gnu/arm/baremetal/i686-pc-linux-gnu/arm-altera-eabi/lib/libjtag_client.so 

/usr/local/altera/14.0/quartus/linux32/libjtag_client.so 

/usr/local/altera/14.0/quartus/linux64/libjtag_client.so 

 

I also want to know whether this problem has relationship with the license. I use the 30-days evaluation license. 

And if anybody use these tools under Linux, can test this to help me make. Thanks in advance.
0 Kudos
8 Replies
Altera_Forum
Honored Contributor I
376 Views

Thanks for letting us know. I'll pass this on to the right people. 

Regards, 

Sue
Altera_Forum
Honored Contributor I
376 Views

 

--- Quote Start ---  

Thanks for letting us know. I'll pass this on to the right people. 

Regards, 

Sue 

--- Quote End ---  

 

 

I'm able to get working in windows machine, where as end up with same error in linux machine. Any update onthis scozart?
Altera_Forum
Honored Contributor I
376 Views

Hi, 

I heard back from engineering. They believe this is related to a known issue. Please retry after either installing the 32-bit libgomp libraries on their machine ('yum install libgomp.i686'), or by launching DS-5 with the Quartus linux32/ directory added to LD_LIBRARY_PATH ('export LD_LIBRARY_PATH="$QUARTUS_ROOTDIR/linux32:$LD_LIBRARY_PATH"; eclipse') and let me know what results you get. 

 

Note that this issue is expected to be resolved in the Quartus 14.1 release. 

Regards, 

Sue
Altera_Forum
Honored Contributor I
376 Views

This issue has not been resolved in the current version of Quartus. I am using version 15.0  

and i got the following error message when trying to debug the example project called:  

 

Altera-SoCFPGA-HelloWorld-Baremetal-GNU 

 

the script file ( device_browser.py ) failed during execution: 

 

error: failed to load client library libjtag_client.so. 

please ensure that the environment variable quartus_rootdir is set to the path to the altera quartus tools installation. 

 

I did the same thing that other guy did, in that i echoed the variable and confirmed that it was  

indeed set properly and it is. 

 

Another thing is that my arm compiler doesn't seem to work due to some licensing error. When I  

try to build any of the ARMCC examples (i know that most of them are for cyclone V, not Arria)  

I get this message: 

 

7:16:31 **** build of configuration debug for project altera-socfpga-helloworld-baremetal-armcc **** 

make all  

building file: ../hello.c 

invoking: arm c compiler 

armcc --cpu=cortex-a9.no_neon.no_vfp -o0 -g --md --depend_format=unix_escaped -c -o "hello.o" "../hello.c" 

product: ds-5 altera edition 5.20.2 [5202025] 

error: c9555e: license checkout for feature altera_compiler5 with version 5.0201411 has been denied by flex back-end. error code: -5 

component: arm compiler 5.05 update 1 (build 106) 

no such feature exists. 

tool: armcc [4d0efa] 

feature: altera_compiler5 

license path: /home/zyvexlabs/downloads/altera/c03fd56ed3f2_1435861502441.dat:/opt/arm/licenses/license.dat: 

flexnet licensing error:-5,357 

for further information, refer to the flexnet licensing documentation, 

available at "www.flexerasoftware.com (http://www.flexerasoftware.com)". 

make: *** [hello.o] error 1 

 

I am using the Arria V Soc Development Board (5ASTFD5K3F4013N). My host/dev PC is an  

intel NUC i5 running Ubuntu 14.04. I have the full quartus licence.  

 

My goal is to create a working architecture for the Arria V SoC Dev Kit which allows us to: 

 

1.) Dedicate one core of the ARM to doing the scan loop and nothing else.  

 

2.) Also the ARM core dedicated to the scan loop cannot be interfered with  

by kernel level interrupts related to other processes being run on the other  

core by a linux smp.  

 

3.) That is to say that the scan loop core should run bare metal or with an  

RTOS (which only support use of one core) making the system as a whole  

an AMP system. 

 

4.) Furthermore one the other portions of the AMP system whether it be the FPGA  

or the other ARM core must be able to run a working TCP stack and have access  

to enough memory in order to facilitate the large size of the buffers that we are moving.  

 

5.) Also one portion of the FPGA must be dedicated to receiving and transmitting  

data from and to the ADCs and DACs.  

 

6.) All of these portions of the system must pass data to and from the bare metal  

scan loop directly (the adc/dac vals and the cmd/stat buffers). This will most  

likely be achieved through very carefully implemented shared memory access. 

 

7.) The preferred implementation would be: 

 

ARM core 1: Bare metal Scan loop ----->[ARM core 1 Memory | shared |] 

ARM core 2: Linux TCP stack----------->[ARM core 2 Memory | memory |]  

FPGA: ADC/DAC vals-------------------->[FPGA Memory______ | access |] 

 

 

8.) However if# 7 cannot be achieved any implementation that satisfies# 1 -# 6  

is acceptable. For example: 

 

ARM core 1: Bare metal Scan loop ----->[ARM core 1 Memory | shared |] 

FPGA: Nios2 Linux TCP stack----------->[FPGA Memory______ | memory |]  

FPGA: ADC/DAC vals-------------------->[FPGA Memory______ | access |] 

 

There are many more options especially when considering the use of RTOSes like  

FreeRTOS or uCosII etc... 

 

As of yet I have been completely unsuccessful in achieving this architecture.  

 

Someone please help me....
Altera_Forum
Honored Contributor I
376 Views

I met this before in the past, where some how the path to the device_browser.py file is not in the PATH environment, I search the location path of the file and added back, after that is works..

Altera_Forum
Honored Contributor I
376 Views

Hi,  

I'm sorry you are having this problem. I have a couple of questions for you:  

 

  • What is your QUARTUS_ROOTDIR actually set to in your DS-5 environment? Does it point to a 64-bit Quartus installation? 

  • Critically, have you actually exported the variable instead of just setting it in your shell? 

  • Can you run 'ldd <actual libjtag_client.so>' on the library you expect to be using? It should be something like $QUARTUS_ROOTDIR/linux64/libjtag_client.so 

 

Please let me know and we’ll try to get this figured out. 

Regards, 

Sue
Altera_Forum
Honored Contributor I
376 Views

I ran into the same problem recently on Linux. In my case, the problem was caused by not having QUARTUS_ROOTDIR defined because I just launched the eclipse from the Ubuntu Desktop "Applications -> Programming". Now I just start a terminal, run "embedded_command_shell.sh" from the SOCEDS installation to setup the environment variables and then launch eclipse from command line. The problem went away after this. BTW, I am using SOCEDS 16.1.

AJama4
Beginner
376 Views

I also ran into the same problem on Windows using the latest 19.1 edition (v5.29.2). The problem was solved when I ran the Ds-5 through the Embedded Command Shell. So there is a difference between directly starting it from Start menu and using the Embedded Command Shell. To avoid the errors, use the latter way.

Reply