Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12455 Discussions

Adding lighttpd-fastcgi to Poky version

Altera_Forum
Honored Contributor II
1,070 Views

Thanks in advance. 

 

I may be going about this all wrong, so please advise. 

 

I've got a Macnica Cyclone V board that has a Poky 8.0 (Yocto Project 1.3 Reference Distro) 1.3 socfpga. 

 

I'm using the lighttpd that came with this distro# ] lighttpd -v 

lighttpd/1.4.31 - a light and fast webserver 

Build-Date: Jun 24 2014 09:52:47 

 

I want to add fastcgi support -- when I've used the Angstrom version it's easy you just need to "opkg install lighttpd-module-fastcgi" 

 

So, I figured I'd add opkg from the Angstrom release and do it that way. Change the lighttpd.conf file to enable fastcgi. 

 

But when I try to start lighttpd I get. 

 

root@socfpga:~# /etc/init.d/lighttpd start 

Starting Lighttpd Web Server: 2014-06-24 05:12:11: (plugin.c.421) plugin-version doesn't match lighttpd-version for fastcgi  

2014-06-24 05:12:11: (server.c.926) Initialization of plugins failed. Going down.  

lighttpd. 

root@socfpga:~#  

 

SO - I figure EITHER 

1. The /etc/opkg/ .conf files are not going to the correct spot to get what I need. Since these go to Angstrom sites. 

2. I can't use opkg. 

 

Can anyone EDUCATE ME? 

Thanks
0 Kudos
0 Replies
Reply