Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

Adding runtime parameter in eclipse

Altera_Forum
Honored Contributor II
1,052 Views

Hello, 

 

I am trying to debug by code in eclipse of Quartus 13.1. Usually to generate the elf, I set the run time parameter in the makefile using CFLAG in nios2command shell as below: 

 

--set CPPFLAGS -dparameter name 

 

where parameter name is the name of the macro parameter.  

 

However, in eclipse I am not able to set the same parameter. I tried to set the parameter from the symbols tab in project properties-> c/c++ general->path and symbols (screenshot attached with the thread).  

 

But this parameter is not set during the eclipse build and I get an error about the same. Did anyone encounter the same problem or is there any way-around. Any help would be greatly appreciated. 

 

Thanks, 

Paul
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
101 Views

The macro name you define must appear in the command line arguments passed to the compiler. As I recall, CPPFLAGS isn't there. Try putting your -dparameter=value in CFLAGS instead of CPPFLAGS. You could also modify the command line arguments to include $(cppflags)

Reply