Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12453 Discussions

Arrow SoCKit Evaluation Board: updating Linux Kernel Image from 3.7.0 to 3.14 on Micr

Altera_Forum
Honored Contributor II
853 Views

Hello There, 

 

I have Purchase the "Arrow SoCKit Evaluation Board" and trying to run my ARM based application over it. 

 

due to limitation of kernel version (Jumbo IP packet) i am not able to properly execute my application on.  

 

so please suggest me how do i update it's Kernel Image...? 

 

Attached is the Print-Screen of Error while running my application. 

 

Regards 

kaushal
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
148 Views

 

--- Quote Start ---  

Hello There, 

 

I have Purchase the "Arrow SoCKit Evaluation Board" and trying to run my ARM based application over it. 

 

due to limitation of kernel version (Jumbo IP packet) i am not able to properly execute my application on.  

 

so please suggest me how do i update it's Kernel Image...? 

 

Attached is the Print-Screen of Error while running my application. 

 

Regards 

kaushal 

--- Quote End ---  

 

 

Hi Kaushal, 

 

I am looking for an answer to the same question. I am working on the arrow sockit board too. I am trying to execute a bash script, but because the kernel of the linux distribution (linaro 13.04) I am using is 3.12* I get the message that I should have a 3.13* kernel instead of 3.12*. 

I tried to follow the instructions of this page : http://www.cyberciti.biz/faq/linux-kernel-upgrade-howto/ 

and precisely, the section "upgrade the kernel in Debian or Ubuntu Linux" but when I type the command apt-cache search linux-image I get a lot of versions (for different platforms, other that arm cortex a 9) and I don't know which one to install. 

I tried to follow the instructions of this page too : http://ubuntuhandbook.org/index.php/2014/04/installupgrade-to-linux-kernel-3-14-in-ubuntu-or-linux-m... 

but the .deb packages that I download are for amd64 and not arm. 

 

Does anyone have a suggestion as of how to solve this problem?
Altera_Forum
Honored Contributor II
148 Views

Hello rukawa, 

 

I got little idia i to upgrade ALtera SoCKit but my aim is to upgrade from kernel 3.7 to 3.13 or above. 

 

http://www.rocketboards.org/foswiki/documentation/arrowsockitevaluationboardlinuxgettingstarted 

 

The Kernel is available on  

 

http://releases.rocketboards.org/release/2014.06/gsrd/bin/linux-socfpga-gsrd-14.0-cv-bin.tar.gz 

 

But the process which is given on obove link is little different , so just trying to figure out how to resolve it, 

 

kaushal
Reply