Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

BeMicroMAX10: Nios II system skips first pattern of LED sequence at power up only?

Altera_Forum
Honored Contributor II
861 Views

Hi all, 

 

 

I have this board set up so the LEDs show a pattern like this below with a one second delay between them: 

 

 

LED1-LED2-LED3-LED4-LED5-LED6-LED7-LED8 (0=on, 1=off) 

 

 

1110-0111 

1101-1011 

1011-1101 

0111-1110 

1011-1101 

1101-1011  

back to start 

 

 

This works fine except at power up. The first pattern (1110-0111) is skipped. After the first time it works as expected. 

I program the Nios following the tutorial in youtube from altera (link below) with ocram (initialized) and CFM0 . I have no flash ip in my design. 

 

 

https://www.youtube.com/watch?v=0k4azmdw9sk 

 

 

Why can't I see the first pattern? 

 

Thanks
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
100 Views

You need to post some code to help us. The make-up of your qsys system isn't going to hold the answer... 

 

Cheers, 

Alex
Altera_Forum
Honored Contributor II
100 Views

As I was posting the code I saw the problem (i=1 should be i=0) so ... never mind. 

 

Thanks
Reply