Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12452 Discussions

Connecting 2nd Jtag2AVM to f2h_axi_slave causes system console to hang up

Altera_Forum
Honored Contributor II
1,021 Views

Hi, 

 

I'm trying to create my first HPS system on a C5 Soc board from Terasic. 

If I create a system with one JTAG2AVM bridge (called fpga_console in picture qsys_causing_no_error.png) I can run the script shown below, and the leds lit according to the number writen. 

set jtag_master 0] open_service master $jtag_master master_write_8 $jtag_master 0x00010040 1 master_write_8 $jtag_master 0x00010040 2 master_write_8 $jtag_master 0x00010040 3 master_write_8 $jtag_master 0x00010040 4 close_service master $jtag_master  

 

The documentation that I follow from Terasic however tells me that I need to add a second JTAG2AVM Bridge and connect that one up to the f2h_axi_slave (called hps_console in picture qsys_causing_error.png) 

When I do this and try to run the script above again, system consoles timesout with an error (see system_console_error_message.png). 

 

I don't understand that this connection, has influence on the fpga_console, that it not connected at all to the HPS or the hps_console. 

Any advice? 

Is this connection putting the HPS in reset perhaps? 

 

Rgds, 

Kimberley
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
178 Views

The problem is solved (with help from Terasic). 

As I insert another JTAG2AVM bridge, my jtag_master in the script above is not anymore on index 0, but index 1 

So when I change the first line into: 

set jtag_master 1]  

 

the scripts works.
Altera_Forum
Honored Contributor II
178 Views

My friend solved the other two problems. 

She did redo everything I did. 

She started from scratch and did do only what the manual said. 

Apparently I did something wrong (still haven't found what) 

 

The other thing I would like to mention, is that the f2h_axi_slave doesn't work, when the HPS is not loaded with a PRELOADER configuration. 

As soon as that is done, the HPS has clocks and is out of reset. 

And then you can access the LEDS's and BUTTONS trough the f2h_axi slave interface by the HPS-JTAG2AVM bridge.
Reply