Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
782 Views

Custom CycloneV Board based on DE1-SOC, USB3300 issue.

Hi all, 

 

I integrate a part of DE1 board into my system. I'm using the same family of Cyclone V Soc (5CSEMA5F31C8N) and some useful peripherals of DE1. But I took the USB-otg part from DE0-nano(without usb hub) as reference. 

 

With the sd card image provided by Terasic, I'm able to boot the linux. However, when I insert usb-gadget driver and connect my board to PC, I can't see anything under PC windows 7.  

All peripherals are working well except the usb. 

 

The driver module and kernel should be working well because I tested them on a DE-nano board and I was able to see the board detected as a device by PC.  

 

I tried generating preloader and device-tree binary (.dtb) from GRHD found in DE-1 CD ROM, unfortunately it's wasn't better.  

In the boot log, it seems that the usb1 is recognized by the kernel and the dwc driver is loaded correctly. (see attached bootlog.txt) 

 

To understand why the usb is not working, we compared all pin signals connecting to USB3300 chip. We’ve found that all input/output signals are the same except the pin “ID” of USB3300. 

Without sd card inserted, pin “ID” is in floating state(around 2V) when DE0 board and our board power supplied.  

With sd card, pin “ID” turns to high (3.3V) on DE0 board, while it stays at 2V on our board. 

When I remove Uboot(uboot.img), device tree file (*.dtb ) and kernel file(zImage), only Preloader remains in the sd card => there’s still a difference of “ID” pin level on two boards.  

So the problem may come from preloader, but I’m sure that we are using the same hps_isw_handoff from DE0_NANO_SOC_GHRD to generate the preloader. 

 

We are also sure that we use exactly the same schematic and components for USB (chips, resistances, capacities, etc…).  

 

Please find attached the bootlog of our board. (boot + insmod usb driver + lsusb + dmesg | grep usb). 

 

Do you have any idea on this issue?  

 

Thank you for your help.
0 Kudos
0 Replies