Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

Cyclone V SX SoC Development Board serial for HPS

Altera_Forum
Honored Contributor II
838 Views

Hi, 

I have a couple of Cyclone V SX SoC Development Board. 5CSXFC6D6F31C6N The one with the LED display. 

 

I am using the 15.1 SOC install with the blasterii usb to serial with windows 7. 

I have successfully ported apps etc to the arm linux with ds-5 with the gnu gcc cross compiler. 

I am trying to get 4 serial channels to talk to an app on the arm9 processor but for now I would like to just get 1. I would like to stay on the HPS but if I have to go to the FPGA and quartus prime I guess that’s ok. 

I noticed that there are no devices /dev/a_16550_uart_0,1. 

I am using the stock install that comes on the ssd card.  

I see a sample app in the Embedded Peripherals IP User Guide for a loopback serial. 

I saw the example in the ds-5 arm cross compiler the uart 16550 that creates a hwlib.xfe and a u-boot-spl.xfe when I run the hwlib.xfe it segment faults probably because the devices are missing. Is the u-boot-spl.xfe a u-boot.img? I am guessing not because the format of the file looks different. 

I ran the bsp-editor and recompiled the preloader and u-boot but the serial was already checked.  

I did a lsmod and the only module was altera-something. 

So is the uart the best approach for the serial? 

How do I get it into the bsp-editor and linux to include this device? 

Thanks, 

Piglet
0 Kudos
0 Replies
Reply