Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

DS-5 unable to connect (C5-SoC). FLEXnet Licensing error: -88

Altera_Forum
Honored Contributor II
942 Views

Hello, 

 

I have recently attended to a SoCKit workshop to have the first contact with the Cyclone V SoC architecture. Some days later I tried to go again through the steps of the hands-on to be able to see more deeply the workflow which was introduced to us. 

 

At a certain step I have to debug the program in the chip with the Eclipse environment. In the SoC SW Lab step number 3.4 section 4 I get a strange error, which I guess has to do with the license, although I have followed all the steps to license the 30-days evaluation and the environment recognizes it. 

 

The exact error is the following: 

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=7546  

 

Has anybody any clue why can this be happening? 

 

The materials of the seminar can be found here (http://www.arrownac.com/solutions/sockit/) --> getting started --> download the SoCKit lab materials. Inside there is the SoC SW Lab guide which I refer above, in case somebody wants to see the exact context of the issue. 

 

Thank you very much in advance
0 Kudos
5 Replies
Altera_Forum
Honored Contributor II
140 Views

This is probably not related but if you use the LM_LICENSE_FILE variable for references to your DS-5 and Quartus II / IP licenses make sure DS-5 is the first one listed. I've seen some issues when my Quartus II license is listed first.

Altera_Forum
Honored Contributor II
140 Views

I set the problem aside some time but finally I got to solve it. This FLEXnet is an utility which monitores if a certain licensed program is running under a clean PC. That means that it will catch some common "tricks" to evade the licenses limitations and avoid any licensed program to run in such a machine. 

 

In my case, it detected that I had a file modified after the actual date. It interpreted thus that I had changed the date of the machine and that I could be trying to abuse the license. 

 

I could not solve this problem without a format of the whole machine. 

 

In my case, the conflictive file was something inside my TINA-TI installation which I did not modify myself and had a creation data in 2017. Just removing it and reinstalling the whole Altera software did not help.
Altera_Forum
Honored Contributor II
140 Views

I seem to be having a similar problem. I don't know what is causing this as the license.dat (see attachments) file in the license manager was there by default when I first opened DS-5. 

I am using Windows, and want to debug using USB blaster. Any suggestions would be appreciated.  

Thank you.
Altera_Forum
Honored Contributor II
140 Views

Hi, did you solve this bug?

Altera_Forum
Honored Contributor II
140 Views

 

--- Quote Start ---  

I seem to be having a similar problem. I don't know what is causing this as the license.dat (see attachments) file in the license manager was there by default when I first opened DS-5. 

I am using Windows, and want to debug using USB blaster. Any suggestions would be appreciated.  

Thank you. 

--- Quote End ---  

 

something is not right with your license file, as there is no license type under your license window. You got this license ofmr silver arm or altera based web ?
Reply