Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12454 Discussions

Defining Device in Eclipse for HWlibs

AShiv
Novice
1,079 Views

As the question states I am having trouble defining the device in the eclipse DS-5 Arm client for use with HWlibs. I understand I have to add a preprocessor macro with the device, in my case soc_cv_av, but they changed the way the macros are added in eclipse. Here is the old way and how it looks in all the Altera guides found online:

 

However I suppose at some point they changed the interface since much of the project build setting are different so now it looks like this:

Requiring a symbol as well as a value. I've tried:

Symbol: -D      Value: soc_cv_av

Symbol: -d      Value: soc_cv_av

Symbol: ALT_DEVICE_FAMILY      Value: soc_cv_av

Symbol: soc_cv_av      Value: soc_cv_av

 

None of which did anything about the error. It's extremely frustrating. I was able to run a simple hello_world without HWLIBS but now as I am getting into using the bridges I need those files. I appreciate any help thanks!

 

3 Replies
Fawaz_J_Intel
Employee
289 Views

Hello,

Which DS-5 version are you working with, plus which GHRD version is that?

 

Thanks

Fawaz_J_Intel
Employee
289 Views

Hello,

I would like to know if you could manage to solve your issue.

 

thanks

AShiv
Novice
289 Views

Hi FJumaah, sorry I thought I had responded to this. I was using DS5 5.28, GHRD was the one that came with Quartus 18.0. I cant remember the exact version of it though. I came up with a work around by using a makefile based project instead of a Eclipse managed one. Thanks though!

Reply