Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

Does DS-5 AE support using the USB Blaster (Rev C) cable as the connection ?

Altera_Forum
Honored Contributor II
1,464 Views

The documentation for DS-5 says that it supports the USB Blaster II. This works connecting to the USB Blaster II on the eval board. 

 

When I try to connect with a USB Blaster download cable, the debugging doesn't want to load the .axf file. It sees the HPS core on the JTAG chain, but the load always fails. 

 

Should this work ? Or is there a difference between the USB Blaster download cable and the USB Blaster II that is required for DS-5 debugging ?
0 Kudos
5 Replies
Altera_Forum
Honored Contributor II
117 Views

I think this should be working, you sure you have installed the driver correctly?

Altera_Forum
Honored Contributor II
117 Views

I think so. 

 

I can use the blaster II which is built into the dev board fine. 

I can see the items in the jtag chain with jtagconfig fine. 

I can select the usb blaster cable from within ds-5 fine. 

I can do some operations from within ds-5 such as writing a few dwords to OCRAM with the usb blaster cable. 

I've tried two usb blaster cables. 

I've tried a couple of different USB ports on my PC. 

I've tried to have just the HPS on the chain and the HPS & FPGA on the chain. 

 

I had the altera reps in this week and they thought it should work too. 

It seems like its probably signal integrity sort of issue, but the USB Blaster cable is the slowest rate and in theory, if I had a USB Blaster II cable, it would have faster options available, so I would assume that could be worse. 

 

I guess at this point, I'll get a USB Blaster II Cable and then debug my board when its available. I'm not sure I want to invest a lot of time debugging an eval board for signal issues.
Altera_Forum
Honored Contributor II
117 Views

Okay,, are you using both altera build dev kit and altera usb blaster?

Altera_Forum
Honored Contributor II
117 Views

Yes. The eval board is Altera's Cyclone V board (100-0321003-CI REV C) and the USB Blasters are Altera REV C units (the ribbon says P06-18025R-00 RoHS, but I think that is likely the ribbon part number).

Altera_Forum
Honored Contributor II
117 Views

try to ensure you are connect to the correct port,and get the usb blaster driver install as seen in device manager,.

Reply