Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

EDS QSPI programming problem

Altera_Forum
Honored Contributor I
1,253 Views

Hi, i’m using my custom Cyclone V SoC(5cseba5u19i7n) board in combination with QSPI flash (Micron 512Mbit). 

I want to program the NOR flash via USB blaster with SoC EDS Command Shell version 15.0. 

 

When I start up the “SoC EDS Command Shell version 15.0”and type “quartus_hps.exe –c 1 –o PV ”. 

 

After programming done ,I get the following  

"1.send_access_data() error while accessing DP Register. 2.Debug Port Read Buffer reading failure, read_dp_buff() error while accessing AP Register.3.Failed to READ ACCESS to the Physical Reg. 4. Failed to read MPU Module Reset Register."  

I was wondering the JTAG was not nomally working. 

 

Thank you.
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
211 Views

 

--- Quote Start ---  

Hi, i’m using my custom Cyclone V SoC(5cseba5u19i7n) board in combination with QSPI flash (Micron 512Mbit). 

I want to program the NOR flash via USB blaster with SoC EDS Command Shell version 15.0. 

 

When I start up the “SoC EDS Command Shell version 15.0”and type “quartus_hps.exe –c 1 –o PV ”. 

 

After programming done ,I get the following  

"1.send_access_data() error while accessing DP Register. 2.Debug Port Read Buffer reading failure, read_dp_buff() error while accessing AP Register.3.Failed to READ ACCESS to the Physical Reg. 4. Failed to read MPU Module Reset Register."  

I was wondering the JTAG was not nomally working. 

 

Thank you. 

--- Quote End ---  

 

 

I am having the same problem. Have you found a resolution?
Altera_Forum
Honored Contributor I
211 Views

Have you found an answer to this? I am also having the same issue (5CSEBA4U) 

Except mine says "Failed to release reset register of MPU"
Altera_Forum
Honored Contributor I
211 Views

Has anyone resolved this issue? 

 

Thanks 

Kevin.
Reply