Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12472 Discussions

Error: Can't Open project -- Quartus II 6.0

Altera_Forum
Honored Contributor II
5,869 Views

recently encountered many times, previous built project (Quartus II 5.0) can't be opened in Quartus II 6.0, and can't be opened in 5.0 as well. 

 

All files are sitting in the original location, no copy or move operations ever done. 

 

X Error: Can't open project -- you do not have permission to write to all the files or create new files in the project's database directory. 

 

WindowXp, change all files into not READ ONLY, still doesn't work, after trying to open the project, some files automatically return to READ ONLY again. 

 

Please help!
0 Kudos
8 Replies
Altera_Forum
Honored Contributor II
3,852 Views

I've never seen that before, but it shouldn't hurt to delete the db folder in your project. On Windows, these sorts of file permissions issues are usually caused by some sort of stray (or out of control) process that has grabbed control of certain files. 

 

I use process explorer (http://www.sysinternals.com/utilities/processexplorer.html) to find these processes and kill them. 

 

Cheers, 

 

- slacker
Altera_Forum
Honored Contributor II
3,852 Views

Appreciate slacker's suggestion, 

 

We actually have three workstations suffering the same issue. I tried processes killing method, no related process found. 

 

Copy all the project files to a clean computer, the do the properties change still won't work (totally windows thing). 

 

Could not understand why.
Altera_Forum
Honored Contributor II
3,852 Views

 

--- Quote Start ---  

originally posted by legendbb@Jun 28 2006, 12:39 PM 

appreciate slacker's suggestion, 

 

we actually have three workstations suffering the same issue. i tried processes killing method, no related process found. 

 

copy all the project files to a clean computer, the do the properties change still won't work (totally windows thing). 

 

could not understand why. 

<div align='right'><{post_snapback}> (index.php?act=findpost&pid=16470) 

--- quote end ---  

 

--- Quote End ---  

 

 

I saw that the files in the project lost write permission. Try to put them.
Altera_Forum
Honored Contributor II
3,852 Views

I have the same problem. 

It first occurred in my Nios project, but not in my non-Nios projects. 

I then created a new project containing a Nios block, and I used it for about a week. It worked when I left the office last Friday, but when I returned Monday morning this project was also impossible to open. 

The last time I could use it by opening it on another computer and then just opening the sof file on my own computer when it was time for programming, but I haven&#39;t tried that with this project yet.
Altera_Forum
Honored Contributor II
3,852 Views

I have solved the problem. 

I removed all files that I believe are temporary or generated automatically. Actually I removed all files and left it to my revision system (Perforce) to re-sync the files. 

After this the project could be opened. 

 

The next time it happens I will remove the files one by one in order to find out which one is causing the trouble.
Altera_Forum
Honored Contributor II
3,852 Views

The problem is that somehow (don&#39;t ask me - i don&#39;t know) windows sets the write protection bits to several files and to directories.  

 

You can check this in windows explorer if you press the right mouse button to the bar where Name, Size, Type and Date Modified is shown. Select the Attributes field. If an &#39;R&#39; is shown for any of the files or directories in your project directory, then you have this problem. 

 

To solve this you have to open a DOS box (start menu -> Run... -> enter cmd and press OK, change to the project directory and run 

 

&#39;attrib -R /S /D *&#39;  

 

This should clear all write protection flags for the files in this and all subdirectories (including the directories)

 

It is not necessary to delete or reinstall anything. 

 

If one knows how to do this in windows explorer then please let me know, because i can remove write protection only on files, but not on directories. 

 

Hope this helps 

Klaus
Altera_Forum
Honored Contributor II
3,852 Views

 

--- Quote Start ---  

originally posted by stonie@Aug 28 2006, 05:05 PM 

to solve this you have to open a dos box (start menu -> run... -> enter cmd and press ok, change to the project directory and run 

 

&#39;attrib -r /s /d *&#39; 

--- Quote End ---  

 

 

It helped if I run on &#39;.&#39; instead of &#39;*&#39; when I was located in my project directory. 

Why, I don&#39;t know. I also don&#39;t understand what the difference is between the ATTRIB command and changing attributes from the Properties window. 

 

Thanks for the help. 

 

/Mattias
ProfEvans
Beginner
2,787 Views

I was having the same issue and this worked perfectly for me.

Reply