Community
cancel
Showing results for 
Search instead for 
Did you mean: 
VinayGB
Novice
375 Views

Error in migrating NIOS project from Quartus 14 to Quartus 20.1

Jump to solution

I have a FPGA&NIOS project built using Quartus14.1. To migrate this project to version 20.1, it was opened in 20.1, FPGA project was built and programming file was generated. Using this SOPC file, I tried to build NIOS project(after regenerating BSP in NIOS SBT). Error show is as in image-2.jpg

I tried to use the BSP generated from Quartus20.1, use the SOPC file and create a new HelloWorld project. Error in creation of new project is as in image-1.jpg.

I tried both of the above by opening NIOS SBT as administrator. But errors remain same.

Quartus is installed in default location and eclipse for nios is installed as per instructions(extracting folder in to bin and replacing files).

Kindly support in resolving these issues.

0 Kudos
1 Solution
VinayGB
Novice
357 Views

I found the solution.

I had not installed wsl which resulted in all the errors.

After going through the process(rather painful) of updating windows 10, installing wsl ubuntu, I could create a new project.

The old version NIOS project is still not getting built, but I could add all the old files to the new project.

It seems like Intel wants to scare away all old-school Altera users by complicating installation process, which is far simpler in other softwares like Xilinx Vivado or Microsemi Libero.

Anyways, problem is resovled.

regards,

Vinay

View solution in original post

3 Replies
Isaac_V_Intel
Employee
366 Views

Hello VinayGB,

 

I'm Isaac and I'm going to help you through this case.

 

First, the error that shows at the image-2.png you try clean and rebuild?

 

If not, try these steps.

 

  • Edit the application project and library project makefiles and add the inserted code as shown in.
  • Right-click the BSP project, point to Nios II, and click Generate BSP.
  • Clean and rebuild the application and library projects.

 

The second error that shows at the image-1.png, try to launch Nios® II Software Build Tools for Eclipse via Nios® II Command Shell.

 

Let me know if it works.

If not, please share your project with us to do some debugging.

 

Best regards.

Isaac Vazquez.



VinayGB
Novice
360 Views

Hello Isaac,

Error-1 - image2

Clean and build didn't work.

In the steps afterwards, 

Edit the application project and library project makefiles and add the inserted code as shown in.

- link or the code is missing.

Error-2 - image1

Nios® II Command Shell doesn't open. When I click on the icon, it just flashes and goes off.

regards,

Vinay

VinayGB
Novice
358 Views

I found the solution.

I had not installed wsl which resulted in all the errors.

After going through the process(rather painful) of updating windows 10, installing wsl ubuntu, I could create a new project.

The old version NIOS project is still not getting built, but I could add all the old files to the new project.

It seems like Intel wants to scare away all old-school Altera users by complicating installation process, which is far simpler in other softwares like Xilinx Vivado or Microsemi Libero.

Anyways, problem is resovled.

regards,

Vinay

View solution in original post

Reply