Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12419 Discussions

Error: (vsim-3828) Could not link vsim_auto_compile.dll

Altera_Forum
Honored Contributor II
1,284 Views

Good Morning, 

I created a system by means of the Quartus Qsys composed by a SoC (hard processor system - hps) and an Avalon Slave. 

The Qsys generated all the files for synthesis and simulation, together with the compilation script for Modelsim. 

However, I had an error in Modelsim after launching the script (after the vsim): 

error: (vsim-3193) load of "c:\altera\14.0\ip\altera\mentor_vip_ae\common_windows_10_1/questa_mvc_core/win32_gcc-4.2.1/libaxi_in_systemverilog_mti_full.dll" failed: dll dependent library not found.# # ** error: (vsim-8649) initialization function 'axi_in_systemverilog_load' not found. 

So, I downloaded the UVM libraries from the accellera website and I compiled them using the command 

vlog +incdir+c:/modeltech_pe_10.4a/uvm-1.1a/src c:/modeltech_pe_10.4a/uvm-1.1a/src/uvm_pkg.sv c:/modeltech_pe_10.4a/uvm-1.1a/src/dpi/uvm_dpi.cc 

 

After relaunching the script, I got a fatal error: 

# compiling c:/users/gborri~1/appdata/local/temp\gborriello@l-it-08277_dpi_7312\win32pe_gcc-4.2.1\exportwrapper.c# ** fatal: ** error: (vsim-3828) could not link 'vsim_auto_compile.dll': cmd = 'c:/modeltech_pe_10.4a\gcc-4.2.1-mingw32vc9\bin\gcc.exe -shared -o "c:/users/gborri~1/appdata/local/temp\gborriello@l-it-08277_dpi_7312\win32pe_gcc-4.2.1\vsim_auto_compile.dll" c:/designes/smh_flash_programmer/project/fr2_fpga/soc_system3/soc_system_simple/testbench/mentor/libraries/work\_dpi\auto_compile@\win32pe_gcc-4.2.1\*.o "c:/users/gborri~1/appdata/local/temp\gborriello@l-it-08277_dpi_7312\win32pe_gcc-4.2.1\exportwrapper.o" -l"c:/modeltech_pe_10.4a/win32pe" -lmtipli'# # (vsim-50) a call to system(c:/modeltech_pe_10.4a\gcc-4.2.1-mingw32vc9\bin\gcc.exe -shared -o "c:/users/gborri~1/appdata/local/temp\gborriello@l-it-08277_dpi_7312\win32pe_gcc-4.2.1\vsim_auto_compile.dll" c:/designes/smh_flash_programmer/project/fr2_fpga/soc_system3/soc_system_simple/testbench/mentor/libraries/work\_dpi\auto_compile@\win32pe_gcc-4.2.1\*.o "c:/users/gborri~1/appdata/local/temp\gborriello@l-it-08277_dpi_7312\win32pe_gcc-4.2.1\exportwrapper.o" -l"c:/modeltech_pe_10.4a/win32pe" -lmtipli) returned error code '1'.# # the logfile contains the following messages:# # c:/designes/smh_flash_programmer/project/fr2_fpga/soc_system3/soc_system_simple/testbench/mentor/libraries/work\_dpi\auto_compile@\win32pe_gcc-4.2.1\uvm_dpi.o:uvm_dpi.cc:(.eh_frame+0x11) : undefined reference to `__gxx_personality_v0'# collect2: ld returned 1 exit status# # # result too large. (errno = erange)# # # # fatal error while loading design# error loading design 

 

Anyone knows how to solve this? 

Thanks, 

Guido
0 Kudos
0 Replies
Reply