Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12453 Discussions

Errors trying to instantiate flash in SOPC Builder

Altera_Forum
Honored Contributor II
975 Views

I'm trying to instantiate a flash device in SOPC Builder. 

 

I instantiate the Flash Memory Interface(CFI) with a template of Intel 256P30. I instantiate my Avalon-MM Tristate Bridge. I hook them up and get the following error: 

 

Error: cfi_flash_0.s1: Master tri_state_bridge_0.tristate_master does not have a waitrequest signal. Slave must match master's read and write wait time (read:0 write:0) 

Error: tri_state_bridge_0.tristate_master/cfi_flash_0.s1: Signal tri_state_bridge_0.tristate_master[0] and signal cfi_flash_0.s1[16] must have the same data width 

 

 

Any suggestions? 

 

 

Version is Quartus 12.1sp1
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
126 Views

Hi, 

 

I have the same problem issue, have you already fixed it? Please share me your experience. 

 

Thanks a lot! 

 

Version is also Quartus 12.1sp1
Altera_Forum
Honored Contributor II
126 Views

Hi, I have the same problem. Could you please if you already fixed it, send me a e-mail to me. I'm using version Quartus 13.0sp1. Thanks for your kindness.:-P

Altera_Forum
Honored Contributor II
126 Views

Hello guys! 

I'm trying to execute the memory test template. I select the option to test flash.  

I have checked in the system.h file that the name of the flash is /dev/ext_flash. But when I type in the same name in the nios console, it shows an error 

saying : could not open "/dev/ext_flash" 

 

any idea how to eliminate this error? 

 

Thanks in advance.. any advice is welcome.
Reply