Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

Fix System ID Properties in Nios II

Altera_Forum
Honored Contributor II
1,168 Views

When I go under Run configuration for my Nios system, It can not locate any of the system ID Properties. Does anyone know a way to fix this? 

I have inspected all of my Platform Designer/Qsys and my main Quartus Project. All of them successfully build, generate, and compile with no errors. I am assuming this is some kind of memory mapping issue, but the addresses in system.h seem correct. (java.lang.Exception) is the error that it displays when I try to run my system on the board (Max10). I did push the .sof file onto the chip ahead of time.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
358 Views

I figured this out. It has to do with the Programer in Quartus' Auto detect keeps changing what my Max10 board is for some reason. The solution was to reprogram it and then go to run configurations in Nios. Delete the current Nios II launch configuration and just create a new one. I think many other people had this problem I am using the evaluation kit, but I did not see the solution posted on the forum anywhere. I wanted to share for those who come across it to save them the headache.

Reply