Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
785 Views

Frequent JTAG problems with NIOS II on DE1

We built out an electronics lab with 30 DE1 boards, and built a NIOS II system to do some microprocessor labs. So far we've been very happy with the platform overall, but there's been constant jtag connection issues for us, as well. (The machines in the lab are running 32-bit Windows 7, but my 64-bit Win 7 laptop has similar issues, though not as often it seems.) 

 

The big ones are: 

1) Often, when setting up the debug configuration, Eclipse warns that there is no device attached, and pressing refresh on the Target Connection tab only works sometimes. (Sometimes pressing it twice works? Sometimes it never works, and you have to restart eclipse.) 

2) In relation to the first part, after getting it working once, when you shut down the system and come back to it the next day, if you press the debug button directly, you almost always get 'The system console model is invalid.' error. After getting it today I immediately dropped to a command prompt to get the jtagconfig info: 

 

C:\altera\12.0sp1\quartus\bin>jtagconfig 

1) USB-Blaster [USB-0] 

Unable to read device chain (JTAG chain broken) 

 

So I ran it again immediately, and... 

 

C:\altera\12.0sp1\quartus\bin>jtagconfig 

1) USB-Blaster [USB-0] 

020B30DD EP2C(15|20) 

 

Even after 'preheating' the jtag like this, you STILL have to manually go into debug configurations and press 'Refresh Connections' almost every time. Usually that works. Sometimes you have to restart eclipse again.  

 

Note that it's almost always Eclipse that needs to be restarted. Power cycling the board never seems to be the issue (at least it's never fixed it as far as I know.) 

 

Any guesses as to what's happening? Or how I can ensure the jtag server is starting properly and/or get more ACTUAL details on the 'System console model is invalid.' error?
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
54 Views

I have had similar issues with Eclipse with no luck working around them reliably in Eclipse. I opt to avoid using Eclipse to load the software. Instead, I make use of the Nios2 terminal. It is installed along side Eclipse. 

 

When loading your software using the terminal, you will need to browse to the location of your .elf file. To download your software, use the following command "nios2-download -g XXX.elf". Where XXX is your elf's file name.  

 

Use the "nios2-terminal" command to access the terminal I/O of your Nios. 

 

I hope this helps.
Altera_Forum
Honored Contributor I
54 Views

I'll have to try that next time I run into the error to see if it connects. That doesn't really help if the students are trying to debug though, since you need eclipse for the graphical debugger... 

 

I had one today on my laptop, after about 4-5 edit->save->debug cycles, it just suddenly started giving 'System console model is invalid' errors. Had to go into Debug Configurations and click refresh about 5 times to get it to show up again.
Reply