Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

GLIBCXX_3.4.11 not found

Altera_Forum
Honored Contributor II
832 Views

Helo, 

 

After upgrading my gcc version, my ubuntu screen became blank(after login), i dont know what i have to do 

 

what i did  

 

1)Alt+Ctrl+F1---->after login it show errors like 

 

/opt/quartus/linux/libstdc++.so.6:version 'GLIBCXX_3.4.11' not found (required by /usr/i386-linux-gnu/libproxy.so.1) 

 

solution 

 

sudo mv libstdc++.so.6 libstdc++.so.6.orig 

sudo ln-s /usr/lib/libstdc++.so.6.0.9 libstdc++.so.6 

and libgcc_s.so.1 also i did the same, then its working  

 

2)Very next day its showing error like 

 

apt-config:/opt/quartus/linux/libstdc++.so.6:verison glibcxx_3.4.11 not found (required by apt-config) 

apt-config:/opt/qurartus/linux/libstdc++.so.6:version 3.4.15 not found (required by /usr/lib/i386-linux-gnu/libapt-pkg.so.4.12) 

 

again i repeated the solution its showing libstdc++so.6 and libstdc++so.6.orgic are same, failed to create symbolic link, libstdc++.so.6: file exits 

 

 

Kindly any help i dont know what i have to do. 

 

 

Thanks, 

Alex.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
71 Views

stop multiposting. multiple messages are removed 

 

It looks like you screwed up your Ubuntu installation. I would suggest to reinstall everything (both Ubuntu and Quartus). Messing with /usr/lib is never a good idea.
Reply