Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

GPS Parcer

Altera_Forum
Honored Contributor II
815 Views

Hello All, 

 

I am currently working on getting GPS data from my receiver to the FPGA and displaying the sentences using Eclipse. I have done this in the past using NIOS without any issues, however when I tried to do this again, I am running into garbled sentences. Here are some specifics: 

  • I am using the RS-232 as my serial device input/output 

  • I have a GPS that runs at 9600 baud with one stop bit, 8 bits of data and no parity 

  • I have correctly instantiated the RS-232 device within my top level compiled and ran. 

  • I have generated the NIOS design with the following warning... 

  • warning: system: "no matching role found for uart_rs232:s1:dataavailable (dataavailable)" 

  • Eclipse compiles everthing fine, however the data I get back is something like this: >&nÊònÊ2¹NJÒnÊãònÊynÒ>Ê 

  • The data does come every second as expected 

 

 

Any help with this would be appreciated.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
83 Views

As an addition to my work, I have tried using various baud rates with the same result. I am currently trying to write my own interface and see if that might work. I am using a DE2-115 with Quartus II 11.1.

Reply