Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12409 Discussions

GSRD 14.1 Modifying the kernel

Altera_Forum
Honored Contributor II
942 Views

Thanks in advance. 

With on the Cyclone 5 dev kit in GSRD 13.1 I used:# ] cd yocto# ] source ~/yocto/altera-init ~/yocto/build_tag# ] "bitbake -c menuconfig -f virtual/kernel 

modified what I needed ...# ] bitbake virtual/kernel 

So, I've moved to GSRD 14.1 and I've built the default kernel as per the instruction on:  

http://www.rocketboards.org/foswiki/documentation/gsrd141compilinglinux 

$ cd ~ 

$ git clone http://git.rocketboards.org/linux-socfpga.git  

$ cd linux-socfpga 

$ git checkout -b test_branch ACDS14.1_REL_GSRD_PR 

$ export CROSS_COMPILE=~/gcc-linaro-arm-linux-gnueabihf-4.8-2013.12_linux/bin/arm-linux-gnueabihf- 

$ make ARCH=arm socfpga_defconfig 

$ make ARCH=arm zImage 

I tried that image on the SDcard and it worked. I need to add USB support for Pata (compact flash) 

Off of the USB to go port. So, I tried this: 

$ cd ~/linux-socfpga 

$ make ARCH=arm menuconfig 

I add the PATA driver -- save it. 

BUT when I make it doesn't like the configuration file and it starts asking me all the  

configuration questions. 

 

How do I modify the kernel configuration and recompile the kernel?
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
136 Views

SOLVED - but not eloquently 

 

So, I took the sopcfpga_defconfig and edited it to add the things I needed. If anyone knows the proper way to do this I'd love to know. 

 

Only problem now is in 13.1 the kernel saw the card reader -- in 14.1 it does not.
Reply