Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,951 Views

HPS-FPGA Bridge enableing

Hi All, I am new to the forum and to Altera SOCs, so sorry if I lake elementary knowledge!! I have a Arria 10 development board (http://rocketboards.org/) and I have mounted a linux image on a SD card and it is booting up. what I want to do is to configure the FPGA via linux (with a rbf file). my problem is when I go to "/sys/class/fpga-bridge/" it is empty! I can not check or change the HPS-FPGA bridges status in anyway (e.g. cat /sys/class/fpga-bridge/fpga2hps/enable fails ) Therefore "dd if=file . . . " also fails and I am not sure what the problem is! can the bridges be disabled due to another setting (I am not sure if arria 10 has it but something like fuse bits Etc.) do you have any other thoughts on the issue?

0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
124 Views

quick one, reconfirm all hardware jumper in correct places, then the SDcard you are using is match the SOF file version? example u are using 15.1, better flash 15.1 SOF file for hardware

Altera_Forum
Honored Contributor I
124 Views

But you maybe want to enable bridges in uboot-stage (before loading the Kernel and after programming the FPGA) with e.g. "run bridge_enable_handoff". 

But be aware to have the right settings for the Bridges by using the corresponding SPL (preloader) for the FPGA-Image to have the correct bridge-handoffs
Altera_Forum
Honored Contributor I
124 Views

Oh yea... Taz got a point...

Altera_Forum
Honored Contributor I
124 Views

Hi.. I also have the same issue.. If i use linux-socfpga kernel version 3.18, it shows folders inside /sys/class/fpga-bridge/.. But when i implement it on linux kernel 3.19.6 version, the folder /sys/class/fpga-bridge/ is empty.. I am using the same u-boot for both. I added the driver for fpga bridge with reference to kernel 3.18. The kernel bootlog shows the following. 

 

0.141454] altera_hps2fpga_bridge soc:fpgabridge@0: Could not get hps2fpga reset control! 

[ 0.141467] altera_hps2fpga_bridge soc:fpgabridge@0: probe deferral not supported 

[ 0.141518] altera_hps2fpga_bridge soc:fpgabridge@1: Could not get lwhps2fpga reset control! 

[ 0.141528] altera_hps2fpga_bridge soc:fpgabridge@1: probe deferral not supported 

[ 0.141573] altera_hps2fpga_bridge soc:fpgabridge@2: Could not get fpga2hps reset control! 

[ 0.141583] altera_hps2fpga_bridge soc:fpgabridge@2: probe deferral not supported 

 

Can anybody help. Thanks in advance.
Reply