Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
999 Views

HPS load hangs after RBF is loaded

Hello, 

 

I had a working QSYS design with HPS & FPGA communication through the H2F bus. 

The Linux on the HPS loaded well and everything functioned as intended. 

 

I then decided to enable the F2H bus as well - and now Linux freezes a few seconds after the RBF is loaded. 

 

Notes: 

 

1. I'm using Quartus 16.0 

2. No other changes where made to the design - the delta between the functioning and non-functioning versions is only the added F2H. 

3. The FPGA's RBF loads well and the logic portion of the design works as intended. It's only the software that doesn't.
0 Kudos
5 Replies
Altera_Forum
Honored Contributor I
39 Views

The problem could be in the bridge, 

one option is that it is not initiated during boot, another option is that it is used wrong in the software or hardware. This will cause the HPS to freeze once the bridge is used.
Altera_Forum
Honored Contributor I
39 Views

Please be more specific... 

Or at least point me to an example that describes how this bridge shall be initiated correctly.
Altera_Forum
Honored Contributor I
39 Views

I'm afraid that the "hps freezing" is a fairly common issue when something is wrong, so I can't be super specific (plus the fact that i'm new to SoC design myself). 

What platform are you using? You could take a look at the reference designs http://www.terasic.com/downloads/cd-rom/de0-nano-soc/. there a few example projects in that folder, along with some guides on how to use them
Altera_Forum
Honored Contributor I
39 Views

I'm using the Terasic SOCkit with Ubunto.

Altera_Forum
Honored Contributor I
39 Views

I found this topic yesterday which might be of interest to you 

http://www.alteraforum.com/forum/showthread.php?t=47099
Reply