Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
3,795 Views

Help: Simple Socket Server - Stratix IV GX

Hello,  

 

I have a very basic knowledge on FPGAs and Verilog, as I only started to learn about it this semester. my final year project is quite big as I have to implement a PoE structure then make connection with the FPGa board then finally adding a sensor to system. For now I needs to build a simple socket server work on my FPGA board Stratix IV.  

 

I have looked through the forum and found this article, which explains nicely on how to build one  

 

http://www.alteraforum.com/forum/showthread.php?t=28837 

 

but there are things that I did not understand because of different board.  

 

what does this mean (DE2_115_WEB_SERVER_RGMII_ENET0 demo) ad where can I find the demo that is suitable for my board.  

 

 

honestly I don't know where to start,  

 

please any guidelines will really be helpful .  

 

Thanks You  

 

0 Kudos
27 Replies
Highlighted
Honored Contributor I

 

--- Quote Start ---  

can you try to force your pc to this ip address : 192.168.1.1, gateway is the same as last reply (look above), same for mask. if it still doesnt work, try to force you pc to 1Gb/s or 100M or whatever, but don't let it auto negociate speed. (i read something like this in this forum when someone tried to direct link his pc to his card) 

i can't really help you further if it doesn't work. I'm sorry. : ( 

--- Quote End ---  

 

 

Hi I have disabled the DHCP from the BSP editor. Then gave a static IP of 192.168.1.234, then I run it and here are the results,  

I have noticed that LED D23 keeps blinking and the RX LED of ENET is blinking too but what does that "yyyyyyyyyyy" mean ????!!!
0 Kudos
Highlighted
Honored Contributor I

i dont think it s a problem. Does it respond to ping now?

0 Kudos
Highlighted
Honored Contributor I

 

--- Quote Start ---  

i dont think it s a problem. Does it respond to ping now? 

--- Quote End ---  

 

 

No ,, it says destination host unreachable
0 Kudos
Highlighted
Honored Contributor I

try with a cross over cable.

0 Kudos
Highlighted
Honored Contributor I

 

--- Quote Start ---  

try with a cross over cable. 

--- Quote End ---  

 

 

odd thing happen the board turned on a red light on the error LED D27, and the connection failed, I tried the cable on other device and it works so the issue is not on the cable could it possibly be the board ?
0 Kudos
Highlighted
Honored Contributor I

 

--- Quote Start ---  

try with a cross over cable. 

--- Quote End ---  

 

 

I tried all the possible ways !!! my webserver works !!! and ping can be established!!! but the telnet session doesn't work !!??? any idea !! 

 

please help !!  

 

though the webserver and ping works fine I have this error  

 

------------------------------- 

 

InterNiche Portable TCP/IP, v3.1  

 

Copyright 1996-2008 by InterNiche Technologies. All rights reserved.  

prepped 1 interface, initializing... 

mctest init called 

IP address of : 192.168.1.66 

dtrap - needs breakpoint 

dtrap - needs breakpoint 

Error sending DHCP packet on iface 0. 

ip_exit: calling func 0x1801b6f0 

ip_exit: calling func 0x18023298 

 

-------------------------------- 

 

Attached shows the web server and the ping working successfully  

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=12491
0 Kudos
Highlighted
Honored Contributor I

i can t see anything on your screenshot (too small).

0 Kudos
Highlighted
Honored Contributor I

 

--- Quote Start ---  

i can t see anything on your screenshot (too small). 

--- Quote End ---  

 

 

its just the result of web server and ping  

https://www.alteraforum.com/forum/attachment.php?attachmentid=12495
0 Kudos