Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

How to enable the nios 2 IDE?

Altera_Forum
Honored Contributor II
794 Views

Hello, I've used the Nios 2 IDE before but now I've installed a new Quartus II Web Edition and the Nios 2 IDE is not available, instead when I start the "Nios 2 build tools for eclipse" from Quartus II, what starts is eclipse in C/C++ perspective and it's not possible to make a new Nios 2 project. What am I doing wrong?

0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
94 Views

Nios IDE is obsolete and it was used up to Quartus version 9 or 10. 

Newer Quartus versions only support the Nios SBT for Eclipse. Anyway you should have the same functionalities, although with a different graphical organization.  

IIRC when I switched from Quartus 9 with IDE to Quartus 11 with Eclipse, it was not so a great problem. 

Probably you only have to change the windows perspective or browse the menus for the command you need.
Altera_Forum
Honored Contributor II
94 Views

Thank you for the answer. I start the program C:\altera\12.1sp1\nios2eds\bin\eclipse-nios2.exe and it is just giving me the C/C++ perspective which I tried to change to the Nios 2 perspective but it just won't. I'm all stuck at what to do next. When I now start the program I get "Workspace in use or cannor be created, choose a different one" whereupon as I've changed workspace to C:\Users\dev\nios2-ide-workspace and loading the GUI for the Nios SBT ("Nios IDE") then it is only giving me the C/C++ perspective again. It is wrong.

Altera_Forum
Honored Contributor II
94 Views

I posted a question on stackoverflow about this since I really want to solve the problem: http://stackoverflow.com/questions/16297878/how-to-run-nios-2-sbt 

Thank you /Niklas
Reply