Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12453 Discussions

How to enable tx_clk of the 88e1111

Altera_Forum
Honored Contributor II
1,041 Views

Dir Sir, 

I'm using Cyclone III development kit. I want using Ethernet IP with mii standard to transfer data via Ethernet. and I want using 100Mbs standard. However, this kit not support tx_clk from PHY 88E1111. If I want to use 100Mbps, what should I do? I also buy a HSMC-NET of terasic, then I connect this this with Cyclone III via HSMC port. I used tx_clk for my Ethernet. however, tx_clk is not active clock. How to enable clock this pin from PHY 88e1111? 

Thank you so much.
0 Kudos
6 Replies
Altera_Forum
Honored Contributor II
145 Views

Check if You really have all required wires connected to do MII connection. Maybe there are only wires for RMII?

Altera_Forum
Honored Contributor II
145 Views

Thank you for your help, 

I double-checked connect. only have got 2 types are MII and GMII, not RMII.
Altera_Forum
Honored Contributor II
145 Views

Then MII should work fine. Are You forcing 1Gbit network to work on 100Mbps? Did You tie 1000Mbps setting in MAC to '0'?

Altera_Forum
Honored Contributor II
145 Views

I only want working on 10/100Mbs. therefore, I need 2 clock are tx_clk and rx_clk for the Ethernet-mac. I also built the system on Stratix III kit. However, when i plug Ethernet cable the rx_led and tx_led are not blinking. I's using signal-tab to capture enet_tx_clk and enet_rx_clk are not oscillate

Altera_Forum
Honored Contributor II
145 Views

Check PHY reset signal, is it high? Did You implement reset bug-fix? Check 88E1111 PDF for proper PHY initialization setup. You need to de-assert reset at required time.

Altera_Forum
Honored Contributor II
145 Views

Ok, I checked reset signal and I fixed this pin. Now, the rx_led was blinking. However, when I'm using signal-tap the rx_clk and tx_clk ware not oscillite. please help me :(

Reply