Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
2,003 Views

Install Quartus 12.0 in the 64bit of Ubuntu 12.04

1.Download offline version install file and unzip it 

https://www.altera.com/download/software/quartus-ii-we 

 

2.Run command 

...<your_folder>/12.0_178_quartus_free_linux/altera_installer/bin/altera_installer_gui --gui 

 

3.Select ...<your_folder>/12.0_178_quartus_free_linux/ 

and Select install target folder (where you want file installed) 

 

4.Manually install 64bit part 

cd to ...<your_folder>/12.0_178_quartus_free_linux/linux_installer/quartus_free_64bit/ 

run install 

type your install folder path 

choose "n" for not delete installed files 

 

5.Setting USB blaster 

Create a new file at /etc/udev/rules.d/51-usbblaster.rules 

 

copy and post 

# Altera USB-Blaster rule to set mode to 666. SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", SYSFS{idVendor}=="09fb", SYSFS{idProduct}=="6001", MODE="0666", NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}", RUN+="/bin/chmod 0666 %c" 

 

sudo udevadm control --reload-rules 

 

6.setting QUARTUS_ROOTDIR in the shell 

export QUARTUS_ROOTDIR="your quartus folder" 

 

That's almust everything about it .... 

 

Also share with google + 

Enjoy & Regards, 

Kqalea C
0 Kudos
11 Replies
Highlighted
Honored Contributor I
75 Views

Hi all 

 

If your blaster didn't works and error message like this  

 

1) USB-Blaster variant [2-2] 

Unable to lock chain (Insufficient port permissions) 

 

Will 

 

You need run jtagd at root permissions 

 

For example that i start my quartusII by console  

 

sudo su  

....../....../quartus/bin/jtagd 

...../......./quartus/bin/jtagconfig 

 

it should like this 

root@#######:/home/kqalea/FPGA/quartus/bin# ./jtagd 

root@#######:/home/kqalea/FPGA/quartus/bin# ./jtagconfig  

1) USB-Blaster [2-2] 

020B30DD EP2C(15|20) 

 

then run su back to your account like su kqalea for example 

 

Blaster now nicely working for you 

 

Regards 

Kqalea C
0 Kudos
Highlighted
Honored Contributor I
75 Views

You shouldn't need to run jtagd as root on any Linux platform. 

 

If it's not working then you probably got the rules wrong - please copy the file from http://www.altera.com/download/drivers/dri-usb_b-lnx.html 

 

If jtagd isn't working then please check the permissions on the appropriate /dev/bus/usb/<bus>/<dev> device as this is the one which jtagd will be using. You can temporarily run jtagd in a separate shell with the --foreground argument to find out which devices it's trying to open.
0 Kudos
Highlighted
Honored Contributor I
75 Views

Hello, 

 

 

 

I installed quartus on ubuntu10.04 ,its working fine.Because of some problems i changed ubuntu10.04 to ubuntu12.04,can i folow the same procedure? that means, 

 

 

1,i have given permissions like  

chmod +x 11.1sp1_216_quartus_free_linux.sh 

bash ./11.1sp1_216_quartus_free_linux.sh 

after USB blaster rules, bash./setup. 

 

then its working nicely. 

 

Now in my ubuntu 12.04 its showing like /bin/sh -> dash, instead of /bin/sh -> bash. 

Now my question is can i follow same procedure like what i did in ubuntu10.04, if not please tel me the step by step procedure. 

 

 

 

Thanks in advance.
0 Kudos
Highlighted
Honored Contributor I
75 Views

Hmm~~ 

 

I don't really know , i hadn't try install Quartus 11.1 before  

So i don't know what's inside the installation shell script  

 

But I don't see any thing else can cause fail if you can install Quartus11.1 at ubuntu10.04 

 

Just try it ,  

 

Regards, 

Kqalea C
0 Kudos
Highlighted
Honored Contributor I
75 Views

Hi, 

 

 

But u posted as quartus on 12.04, what about jtag, how to get jtag rules.Plz tel the procedure am very new to this . 

 

 

 

 

Thanks&Regards, 

Alex.
0 Kudos
Highlighted
Honored Contributor I
75 Views

1) The SYSFS keywords have been removed in latest Ubuntu's udev, ATTR is now used, so the line you have to paste in your /etc/udev/rules.d/51-usbblaster.rules is: 

 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTR{idVendor}=="09fb", ATTR{idProduct}=="6001", MODE="0666", NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}", RUN+="/bin/chmod 0666 %c" 

 

 

2) Then, after reloading the rules with:  

udevadm control --reload-rules 

 

3) Connect the USB Blaster 

 

4) Run quartus_pgm (you may have to cd into quartus' "bin" dir) from a terminal and see what it says. If it complains with something like: 

 

*** The Quartus II software cannot be started because the current platform, 

'linux64', does not appear to be installed in: 

 

Then you just have the 32 bits Quartus and to solve this it is as simple as creating a symbolic link of the "linux" folder (inside the quartus installation) called "linux64" 

 

5) Then running: quartus_pgm -l 

should list the USB-Blaster. Now you can program from the CLI and from the Altera Programming GUI. 

 

Thanks to the ones that got the udev part! Regards.
0 Kudos
Highlighted
Honored Contributor I
75 Views

Hi all, 

 

I installed correctly Quartus 12 in Lubuntu 64 bit 12.04 a few month ago, but after the last Update & upgrade in ubuntu. Now I can't execute Quartus. 

 

When I execute quartus. 

~: /home/.../altera/12.0/quartus/bin/quartus 

~:/home/.../altera/12.0/quartus/bin/quartus: line 71: /home/.../altera/12.0/quartus/linux/quartus: No such file or directory 

 

The quartus file exist. 

~: ls -l /home/.../altera/12.0/quartus/linux/quartus 

~: -rwxr-xr-x 1 ... 262662 jun 1 09:53 /home/.../altera/12.0/quartus/linux/quartus 

 

The line 71 that corresponds to the file launcher "/home/.../altera/12.0/quartus/bin/quartus"is this: 

eval exec "$CMD_NAME $cmd_line" 

 

I didn't find what program was updated in ubuntu and that prevents me from running Quartus. 

 

Someone had the same problem? 

 

Thank you very much,
0 Kudos
Highlighted
Honored Contributor I
75 Views

Hi all again, 

 

I found the solution, it's necessary to install again ia32-libs. 

~: sudo aptitude install ia32-libs or sudo apt-get install ia32-libs 

 

There is a conflict between different library files with Wine 1.5. 

The solution proposed by apt-get or aptitude is uninstall "ia32-libs". 

So should not update wine to 1.5 for the moment. 

I hope someone can be this helpful 

 

Regards
0 Kudos
Highlighted
Honored Contributor I
75 Views

When I run 

$jtagd --foreground 

 

I received the following error 

JTAG daemon started 

Can't bind to TCP port 1309 - exiting 

 

How do I check the permissions on the /dev/bus/usb/<bus>/<dev> device 

 

Thank you.
0 Kudos
Highlighted
Honored Contributor I
75 Views

recently I've tried installing the software on two different machines running Ubuntu 12.04 64-bit and still seem to get errors with file not found or the installer never appearing after the extraction. 

 

We found that installing the ia32-libs package allows us to continue with the normal installer without running installers directly or having to download the entire ISO or larger device packages.  

 

Is there any plan for a pure 64-bit compatible installer?
0 Kudos
Highlighted
Honored Contributor I
75 Views

mm520: the "Can't bind to TCP port 1309 - exiting" error message is probably due to jtagd already running. Kill it first and verify it's not running, then try your command again and check for possible other error messages. 

 

The suggestions in this thread doesn't take into account that different devices have different Product IDs (assumed to be 6001 in top post, this might be different for other users). Tristan's post has the same flaw. For a general solution, check your Product ID and use this, or add all known Product IDs to the udev rules. There is thorough instructions on this, along with trouble-shooting tips, here: http://www.fpga-dev.com/altera-usb-blaster-with-ubuntu/
0 Kudos