Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

Install Tools without DS5

Altera_Forum
Honored Contributor I
1,138 Views

I'm attempting to use an Ubuntu 14.04 virtual private server to build the kernel, distro, and bootloader. 

 

When I try to install the 16.0 EDS I get an error because it is looking for xterm or a gnome-term. I don't need/have graphics. How can I install the toolchain without the DS5 IDE? 

 

Also, I'm a little confused. I'm assuming the baremetal tools are for the bootloaders. Which toolchain is used for Linux userspace code? 

 

Thanks, 

 

Kenny 

 

 

--- Quote Start ---  

Launch DS-5 installation [Y/n]:  

 

 

Info: Failed to run ds-5 Installer, no xterm or gnome-terminal found. 

Press [Enter] to continue: 

 

 

Error: Error running xterm -e  

'/opt/altera/16.0/embedded/ds-5_installer/install.sh --destination  

/opt/altera/16.0/embedded/ds-5': /bin/sh: 1: xterm: not found 

Press [Enter] to continue: 

Info: The baremetal toolchain link was not created. You need to run  

/opt/altera/16.0/embedded/host_tools/altera/ds5_link/ds5_link from the embedded  

command shell after installing DS-5 to create the baremetal toolchain link. 

Press [Enter] to continue: 

Vulture:  

Vulture:  

Vulture:  

Vulture: ls /opt/altera/16.0/ 

embedded/ licenses/ logs/ qprogrammer/ uninstall/  

Vulture: ls /opt/altera/16.0/ 

embedded/ licenses/ logs/ qprogrammer/ uninstall/  

Vulture: ls /opt/altera/16.0/embedded/ 

ds-5_installer/ examples/ 

embedded_command_shell.sh host_tools/ 

embeddedsw/ ip/ 

env.sh version.txt 

Vulture: ls /opt/altera/16.0/embedded/embedded_command_shell.sh  

/opt/altera/16.0/embedded/embedded_command_shell.sh 

Vulture: /opt/altera/16.0/embedded/embedded_command_shell.sh  

WARNING: DS-5 install not detected. SoC EDS may not function correctly without a 

DS-5 install. 

 

 

--- Quote End ---  

0 Kudos
0 Replies
Reply