Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,075 Views

Installing QuartusII and USB Blaster in Fedora 17

Installation of Fedora 17, quartusII web edition v11.1 and DE2 Board. 

 

For those having trouble installing on linux here is what I did to have quartus working on fedora 17: 

1. Downloaded altera installer Linux Version from https://www.altera.com/download/dnl-index.jsp (I did this for quartusII v11.1) 

2. Executed the downloaded script with bash 

3. Followed steps in the setup GUI 

4. Created the file 51-usbblaster.rules in /etc/udev/rules.d directory. With the following content:# ALTERA USB BLASTER 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6001", MODE="0666" 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6002", MODE="0666" 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6003", MODE="0666" 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6010", MODE="0666" 

5. I checked that my computer identified my DE2 board by: 

a) connecting the USB Blaster Cable to the computer. 

b) powering the board (on RUN mode). 

c) typing lsusb at a terminal/shell. 

In the list of devices you should see something like: 

bus 004 device 004: id 09fb:6001 altera blaster 

6. When trying to use tools>programmer>hardware setup> add hardware I got attempted to access jtag server -- internal error code 82 occurred 

7. However the terminal was complaining about something else: error while loading shared libraries: libaxerces-c.so.26: wrong elf class: elfclass32 

8. I followed Hanne's advice in this forum: http://www.alteraforum.com/forum/showthread.php?t=33163 and replaced the correct libaxerces, libicudata and libicuuc libraries for JTAG to work. 

9. I found the needed libraries in: http://rpm.pbone.net/index.php3/stat/4/idpl/18961537/dir/fedora_12/com/xerces-c-2.8.0-5.fc12.x86_64...., http://rpm.pbone.net/index.php3/stat/4/idpl/16684451/dir/fedora_5/com/libicu-3.4-6.2.x86_64.rpm.html. Although it says fedora 12 and fedora 5 it still worked for fedora 17. 

10. Download and extract the RPMs. Then move the proper library files to your <quartus installation directory>/quartus/linux64 directory. (I did it using cp command in terminal) 

 

Hope this helps! 

Best Wishes, 

Alvaro Naranjo
0 Kudos
0 Replies
Reply