Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12435 Discussions

Is the NiosII IDE (Eclipse) compatible with Windows 8.1 64 bits?

Altera_Forum
Honored Contributor II
1,341 Views

Hi everyone, 

 

I am having a strange problem trying to generate a NiosII project (very basic Hello World project from template) on QuartusII 13.0sp1. 

I get a message stating that ".sopcinfo file does not contain any cpu", however I have installed Quartus on a Windows 7 VM and it seems to work fine there. 

Then I tried completely reinstalling it on the Windows 8.1 box and I still have the same issue. 

 

Is there anyone else running QuartusII on Windows 8.1? Any success creating NiosII projects? 

Any special steps to achieve that? 

 

I am looking forward into using Quartus II 13.0sp1 on this Windows 8.1 computer, but so far no success on making it work (see my previous post entitled ".sopcinfo file does not contain any cpu"). 

 

Any input here is deeply appreciated. 

 

Thanks a lot, 

Marcelo.
0 Kudos
6 Replies
Altera_Forum
Honored Contributor II
140 Views

Have you installed patch for cygwin from altera university website? 

ciao
Altera_Forum
Honored Contributor II
140 Views

Hi flz47655, 

 

I didn't know about a patch. Is is specific for 13.0sp1? 

Any chance you can point me to a download link? 

 

Thanks, 

Marcelo
Altera_Forum
Honored Contributor II
140 Views

Hi flz47655, 

 

I have found the patch and installed it. 

Same results. 

In fact I don't see the cygwin cwd message anymore. But it still complains that the .sopcfile doesn't contain any cpu. 

 

Still at a loss here. 

 

Any ideas are most welcome. 

 

Cheers, 

Marcelo.
Altera_Forum
Honored Contributor II
140 Views

Hi, 

 

for all who are looking for the link to the patch, see page [1] for instructions and download the patch via [2]. 

 

[1] http://help.ece.ubc.ca/altera 

[2] ftp://ftp.altera.com/up/pub/cygwin_patch/cygwin_patch.zip
Altera_Forum
Honored Contributor II
140 Views

After patch try recreate project from ground. I haven't this problem with Eclipse for NIOS and W8.1 64 bits

Altera_Forum
Honored Contributor II
140 Views

Looks like after re-creating the project, after the patch, all has worked. 

 

Thanks, flz47655, thanks a lot everyone.
Reply