Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12453 Discussions

Kernel Panic programing fpga from Linux

Altera_Forum
Honored Contributor II
1,086 Views

Hello Community, 

 

I receive the following error when I want to program the fpga from Linux: 

 

fpga_manager fpga0: writing fpga.rbf to Altera SOCFPGA FPGA Manager Unable to handle kernel NULL pointer dereference at virtual address 00000008  

 

The full kernel log is in attachment: kernel-log.txt 

The device tree is in attachment: device-tree.txt 

The kernel defconfig is in attachment: kernel-deconfig.txt 

Device-tree overlay file is in attachment: dtso.txt 

 

I hope u can help me. Thanks in advance. 

 

I use buildroot 2018.05 to build the device-tree, the kernel and all the rest for a Linux Embedded device. 

 

I tried the following kernel versions: rel_socfpga-4.9.78-ltsi_18.07.01_pr and rel_socfpga-4.16_18.06.02_pr from https://github.com/altera-opensource/linux-socfpga but both have the same error.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
259 Views

I think I found a workaround. 

 

This error is caused by 

 

dtc -O dtb -o /tmp/dtbo -@ "$DTSO_FILE" cat /tmp/dtbo > /sys/kernel/config/device-tree/overlays/default/dtbo 

 

Piping the content of the dtbo seems not to work anymore. 

 

The solution is to pipe the name of the dtbo file to the path argument of device-tree overlay. 

 

dtc -O dtb -o /lib/firmware/dtbo -@ "$DTSO_FILE" echo dtbo > /sys/kernel/config/device-tree/overlays/default/path
Reply