Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,140 Views

Linux 2.6 fails / gcc missing / NT not supported?

"Configure Kernel" fails for me, the script cannot find HOSTCC. Upon inspection 

it seems like the installer hasn't installed a native i86 version of gcc, which I asume 

it should have done. 

 

My computer is running Windows NT with cygwin installed, and I have two theories on 

what went wrong: 

 

1. The installer doesn't work with Windows NT. 

 

2. The installer breaks if you already have cygwin installed. 

 

Has anyone gotten it to work on a similar setup?
0 Kudos
5 Replies
Altera_Forum
Honored Contributor I
82 Views

All of the x86 tools should have been installed with the Installshield project. Can you confirm a couple of things for me and then we can work from there to get you up and running. 

 

(1) Does /usr/local/bin/gcc exist? That's where the gcc binary should be found if the installer worked alright. 

 

(2) If you click on 

 

Start -> Programs -> Altera -> Nios II Development Kit 1.0 -> Nios II SDK Shell 

 

Do the following text appear in your console window: 

 

------------------------------------------------ Microtronix Linux Extensions Version 1.0, Built Fri May 7 11:44am EST 2004 ------------------------------------------------
Altera_Forum
Honored Contributor I
82 Views

(1) /usr/local/bin/gcc does not exist 

 

(2) The "Microtronix Linux Extensions" message is not displayed.
Altera_Forum
Honored Contributor I
82 Views

It sounds like something went wrong with the Installshield that we put together for the Nios II Linux Distribution. We're going to look into it today by trying to duplicate your environment as closely as possible. Can you give me the following info? 

 

(1) What's the latest service pack that you have installed with NT? 

(2) Did you install a second Cygwin environment on your workstation (outside of the one that's provided with Quartus/Nios II)? If you did, I'm assuming that you installed it from the Cygwin website? 

(3) Can you confirm that you're using Quartus II 4.0 SP1 and Nios II Development Kit v1.0? 

(4) Where did you install Quartus and Nios II? 

(5) Do you have any previous versions of Quartus / Nios / Nios II lying around in your environment that haven't been uninstalled? 

 

If there's anything else that you think we should know regarding your environment, that will help too.  

 

Once we get the details, we'll begin the process of trying to duplicate the problem and we'll keep you updated with our progress.
Altera_Forum
Honored Contributor I
82 Views

 

--- Quote Start ---  

originally posted by ken@Jun 2 2004, 09:18 AM 

it sounds like something went wrong with the installshield that we put together for the nios ii linux distribution.  we're going to look into it today by trying to duplicate your environment as closely as possible. can you give me the following info? 

 

(1) what's the latest service pack that you have installed with nt? 

--- Quote End ---  

 

 

Microsoft ® Windows NT ® 4.0 1381 Service Pack 6 Multiprocessor Free.  

 

<div class='quotetop'>QUOTE </div> 

--- Quote Start ---  

(2) Did you install a second Cygwin environment on your workstation (outside of the one that&#39;s provided with Quartus/Nios II)?  If you did, I&#39;m assuming that you installed it from the Cygwin website?[/b] 

--- Quote End ---  

 

 

Yes, I had one Cygwin environment installed from earlier, and it is from the Cygwin website. 

 

<div class='quotetop'>QUOTE </div> 

--- Quote Start ---  

(3) Can you confirm that you&#39;re using Quartus II 4.0 SP1 and Nios II Development Kit v1.0?[/b] 

--- Quote End ---  

 

 

Yep, Quartus II 4.0 SP1. NIOS II SDK Shell output: 

 

------------------------------------------------ Welcome To Altera SOPC Builder Version 4.00, Built Mon Nov 10 16:27:12 PST 2003 ------------------------------------------------ ------------------------------------------------ Welcome to the Nios II Development Kit Version 1.0, Built Tue Apr 27 22:05:27 PDT 2004 Example designs can be found in    /cygdrive/d/progs/altera/kits/nios2/examples ------------------------------------------------ 

 

<div class='quotetop'>QUOTE </div> 

--- Quote Start ---  

(4) Where did you install Quartus and Nios II?[/b] 

--- Quote End ---  

 

 

D:\progs\quartus 

D:\progs\altera (i.e., D:\progs\altera\kits\nios2) 

 

<div class='quotetop'>QUOTE </div> 

--- Quote Start ---  

(5) Do you have any previous versions of Quartus / Nios / Nios II lying around in your environment that haven&#39;t been uninstalled?[/b] 

--- Quote End ---  

 

 

No. I installed Quartus, Quartus SP1, the NIOS II package a few days ago, there were no FPGA tools installed on my 

computer before that. 

 

<div class='quotetop'>QUOTE </div> 

--- Quote Start ---  

If there&#39;s anything else that you think we should know regarding your environment, that will help too. [/b] 

--- Quote End ---  

 

 

It&#39;s a SMP machine with two processors, but that seems irrelevant... Also, the Installshield seemed to take a long 

time before doing anything when started, but I assumed it was unpacking something (and it&#39;s only a 550 Mhz machine). 

 

<div class='quotetop'>QUOTE </div> 

--- Quote Start ---  

Once we get the details, we&#39;ll begin the process of trying to duplicate the problem and we&#39;ll keep you updated with our progress.[/b] 

--- Quote End ---  

 

 

Thanks.
Altera_Forum
Honored Contributor I
82 Views

We have confirmed that there is indeed an issue with our Installshield under Windows NT 4.0. We&#39;re looking into it right now and we&#39;ll post an update as soon as we can.

Reply