Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

My first nios build problem

Altera_Forum
Honored Contributor II
1,130 Views

Hi! 

i have been building FPGA projects for some time, but i finally decided to make the jump to NIOS and soft cores. I've been getting the same error whenever i try to make the "my first nios" using the DE0 board and the "Hello world" eclipse build: 

f:/altera/nios2eds/bin/gnu/h-x86_64-mingw32/bin/../lib/gcc/nios2-elf/5.3.0/../../../../../H-x86_64-mingw32/nios2-elf/bin/ld.exe: address 0x10da4 of test3.elf section `.bss' is not within region `onchip_memory2' 

it seems to be related to the JTAG UART, as if i turn off in QSYS it builds correctly in Eclipse, but then no STD-OUT! 

no matter what i do with the QSYS build it doesn't work! the QSYS and HDL build correctly, but when i try to build the project in Eclipse i get the above error. super frustrating. 

any help would be appreciated! 

thanks.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
151 Views

Hi, 

 

You may need to try increasing the On-Chip Memory size, as I don't think this is related to JTAG UART. 

Most likely it is due to BSP editor settings or on-chip memory size.
Altera_Forum
Honored Contributor II
151 Views

Hi, 

Thanks! increasing the size of the memory worked. strange as i used the amount from the tutorial (32768).
Reply