Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

NIOS II Boot Process

Navneet
Beginner
790 Views
NIOS II Flash Programmer, Boot Copier, Booting

Hi,

 

I have a cyclone V FPGA development board 5CEBA4F23C7N with an EPCS64 attached to it for non volatile memory purpose.

 

I created a NIOS II application for it that could be boot loaded to the SDRAM using boot copier.

I Placed an Legacy EPCS/EPCQx1 Flash Controller in the platform designer and set the reset vector to the base address of the EPCS Controller and the exception vector to the on chip memory.

In the software side I edit the BSP settings to to disable all the options as the documents says(Image attached). and changed the region in the linker to ON chip memory.

 

But then when I launch the flash programmer it does nothing. I selected the .sof and the elf file for that project. only thing that appear in the programmer is the generating scripts no problems are shown either.(Image attached)

I even tried to reinstall the whole Quartus software along with the WSL ubuntu18LTS, still the flash programmer does not work.

 

I even tried to generate using mem_init_generate to generate the HEX file  and using the convert in Quartus prime tried to generate the .jif file, but only the hardware side works, the softcore does not get loaded.

Useing Quartus Prime Lite 20.1.1. 

 

Can someone please help me out here..

0 Kudos
3 Replies
James_B
New Contributor II
762 Views

When using the mem_init_generate, make sure to attach the resulting .hex file to the onchip memory in platform designer, then regenerate platform designer, then recompile the project in Quartus. 

-James

 

 
 

 

 

 

 

aikeu
Employee
631 Views

Hi Navneet,


Do you still require help for this?


Thanks.


Regards,

Aik Eu


aikeu
Employee
566 Views

We do not receive any response from you to the previous question/reply/answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply