Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12421 Discussions

NIOS II Code Edits Not Working

Altera_Forum
Honored Contributor II
861 Views

Hi guys, 

 

I've been developing a Quartus Project using the University Program USB Controller., and NIOS II on a Cyclone II DE2. I've also developed a C program which allows the controller to be used with a mouse, using the NIOS II Software Build Tools for Eclipse. Everything was running just fine, but now when I try to edit and change the code, these changes don't correspond when I run the .elf on the board. No matter what changes I make in the code, when I run as NIOS Hardware, it still just runs the old version of the code. I'm not sure if its an issue with my project settings, or if my .elf isn't updating correctly or a problem with my makefile. 

 

Any help would really be appreciated, thanks!
0 Kudos
0 Replies
Reply