Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
193 Views

NIOS II toolchain roadmap / Eclipse broken

Any new about the NIOS II toolchain roadmap?

In Q19.1 Std Eclipse is completely broken with Windows 10, there are a lot of video artifacts during debug that make the screen unreadable. I would like to see an updated version of Eclipse supported with the the Nios plugin.

Tags (1)
0 Kudos
11 Replies
Highlighted
Employee
38 Views

Hi,

May I know the information as below:

  1. Do you have follow the installation steps in chapter 2.1 as link below: https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/nios2/n2sw_nii5v2gen2.pd...
  2. May I know the error message?

Thanks

 

0 Kudos
Highlighted
Beginner
38 Views

1) Yes I followed that instructions

2) There is no error message but the screen is not redrawn correctly and I can't properly see the buttons on the bottom (ex. to switch from the Debug log to the Console)

 

I am on a 4K monitor, using High DPI scaling override "System Enhanced"

 

Thank you

Leonardo

0 Kudos
Highlighted
Beginner
38 Views

Attached an example of visual artifact that I don't have with previous versions of Eclipse/Nios

 

nios.png

0 Kudos
Highlighted
Beginner
38 Views

eclipse.png

0 Kudos
Highlighted
Employee
38 Views

Hi,

I am trying to install the Quartus Prime Standard v19.1 and try to duplicate the defect.

Please allow me to have some time to install to test on the system.

In the meantime, could you provide me the display resolution information?

Thanks

0 Kudos
Highlighted
Beginner
38 Views

Hello,

 

I am using a 4K monitor (and resolution)

 

Thanks

0 Kudos
Highlighted
Employee
38 Views

0 Kudos
Highlighted
Beginner
38 Views

Hi,

 

Thank you for your reply, unluckily it's not a font but a graphic problem and downscaling to 1080 it's not a viable solution for me

 

Cheers,

Leonardo

0 Kudos
Highlighted
Employee
38 Views

Hi,

It is a 4K monitors graphic problem for Quartus Prime software in Window 10.

 

I had just found that the developer had known this issue and plan to solve in future.

 

Unfortunately, the only workaround is downscaling to 1080.

 

Thanks

0 Kudos
Highlighted
Beginner
38 Views

I found another bug, Eclipse is not detecting the System ID, a 0 or "Not found" is displayed when analyzing the target connection (see attached picture).

Using system-console I can read the right data at the system id MM address

Using Nios II Hardware v2 (beta) configuration seem to fix the issue (only some times). but this is very bad!

 

bug.png

 

Today I even found another bug with TimeQuest. If there is an error in the SDC file and you Create the netlist from the GUI the first time you get a message, the second time everything crash!

I'm experiencing a lot of bugs with this new Q19.1 std, should Intel hire me to improve Quartus?

0 Kudos
Highlighted
Beginner
38 Views

Adding another bug...

When creating a project with BSP in Eclipse the project doesn't reference the BSP and the intellisense is broken (show include errors, etc..)

 

Another bug that apply to 19.1 std (windows) as well

 

https://www.intel.cn/content/altera-www/global/zh_cn/index/support/support-resources/knowledge-base/...

 

0 Kudos