Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,411 Views

NicheStack can't initialize the PHY

Good day. 

 

I have a problem with NicheStack and a PHY. 

I am using the 3sl150 Stratix III based devkit. As I am a beginner, I am using NIOS II standard design that comes with the board. As I tried to launch the Simple Socket Server (SSS) application, it could not allocate the PHY (the board's PHY is Marvell 88E1111 that is supported by the driver by default, as it is written in the documentation) and came up with the error: 

 

[tse_mac_init] 

INFO : TSE MAC 0 found at address 0x00001400 

ERROR : MAC Group[0] - No PHY connected! 

ERROR : PHY[0.0] - No PHY connected! Speed = 100, Duplex = Full 

OK, x=401, CMD_CONFIG=0x00000000 

 

The design uses Triple Speed Ethernet in RGMII mode for networking. 

 

There are no other MAC interfaces (like lan91c111) in the design. 

 

What can be wrong? 

 

0 Kudos
5 Replies
Altera_Forum
Honored Contributor I
96 Views

Is the PHY actually responding? Try to capture the MDIO signals with signaltap and check if it is answering the MAC.

Altera_Forum
Honored Contributor I
96 Views

Thanks, I''ll try..

Altera_Forum
Honored Contributor I
96 Views

Finally.. Everything seems to be OK. 

 

If anyone has the problem with networking on 3sl150, please, check this out. This will help. 

 

http://www.alteraforum.com/forum/showthread.php?p=86569#post86569
VOvsi
Beginner
96 Views

Hello, I had the same problem

(INFO : TSE MAC 0 found at address 0x00103000 

ERROR : MAC Group[0] - No PHY connected! 

ERROR : PHY[0.0] - No PHY connected! Speed = 100, Duplex = Full OK, x=401, CMD_CONFIG=0x00000000 ), and the link you gave is not valid. Could you help me?

Liuqian
Beginner
30 Views

Have you solved the problem?Can you communicate me by email aranaagrail@outlook.com

Reply