Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
46 Views

Nios II Debug : No source available for ""

Hi,

I am facing an issue with Nios II Debugger. Actually, I am using Cyclone V SoC Development Kit. I dowloaded the .sof of quartus project and I would like to debug the C code. Unfortunately, when I launch the Debugger, I have an error message without any explanation No source available for "" When I click on View disassembly, nothing happens. I treid to clean and refresh the project, the error is always here. I even tried to rebuild new quartus and Nios II project in a new workspace, it did not change anything.  I do not know if I am missing something, does someone have any idea to fix the issue ?

Thanks in advance,

 

Regards,

0 Kudos
1 Reply
Highlighted
14 Views

Hi @sa_lahrich,

Thank you for posting in Intel community forum and hope this message find you well.
Quick check, have you tried on the Nios II Hello World Small to see if it works in the debug as?
Is the failing of debug happening for both Nios SBT and command line tools?
Which version of quartus are you using? and is it convenient for you to share a screenshot of your qsys design?

Warm regards.

0 Kudos