Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
880 Views

Nios II IDE

Sir, 

i hv created a SOPC design using nios II (s) , jtag, sdram,pio,timer,sysid using Quartus 7.2 and trying to run hello program on this design using Nios IDE 7.2 . Build is successful, however running the program gives Launching->Error starting process . Same problem is encountered with Quartus 8.0. Kindly give solution to eliminate this problem. 

using CycloneII EP2C35F672C6ES Altera's DE2 board 

thnks
0 Kudos
16 Replies
Highlighted
Valued Contributor III
3 Views

Hi ragad, 

 

could you provide any kind of information on how you're trying to run your application. 

 

Are you trying to write your application to flash, or are you trying to debug? Is a .sof file present and downloaded to the board?
0 Kudos
Highlighted
Valued Contributor III
3 Views

Sir, 

Yes I have downloaded SOF file to the FPGA mentioned. This is a regular experiments ( For hello world) our students are performing. I want to extend the design for the Application layer in TCP/IP interface. Kindly clarify. 

Tnx
0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi, 

ok again, how are you trying to launch your project? 

How are you connected to the fpga? 

Is your debugger recognized by your NIOS EDS?
0 Kudos
Highlighted
Valued Contributor III
3 Views

Sir, 

1. Project is launched by following steps. 

. SOPC is built using Quartus II 

. Bdf file created in quartus II and compiled. 

Program 'SOF' file on FPGA cyclone II board.  

NIOs II IDE launced thru SOPC builder then .PTF file selected of corresponding SOPC and 'hello' file program selected and then build the program to run on NIOS processor. 

 

2. JTAG interface is used to connect to FPGA. 

3. I dont undertandhow the debugger is rcognized. 

 

Thx
0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi there, 

 

okay first lets see if your debugger is recognized, but must be if you were able to download the sof file. 

In Nios-IDE choose the menu Run and click on "RunConfiguation" 

There should be a poitn Nios II Hardware and in best case an existing configuration, otherwise create one. 

When you click on your configuration and then on the tab "Target connection", there you should see your debugger.
0 Kudos
Highlighted
Valued Contributor III
3 Views

changed run confg to nios hardware configuration , error was removed 

however program was not running (pause error) 

Reinstalled the Quartus7.2 , working fine !! 

thnx
0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi, 

so everything is working right now? 

 

Glad that I could help
0 Kudos
Highlighted
Valued Contributor III
3 Views

Sir, 

Thanks for the help. I will be extending the same design for the RTOS ( ucos ) and then building application layer using TCP/Ip stack of the ucos. This application layer I will used to query the Tripple Speed Ethernet design I have build.  

I hope u will support for this work also. 

 

Regards 

RSG
0 Kudos
Highlighted
Valued Contributor III
3 Views

Sir, 

created new SOPC design with Nios 2 , jtag, sdram, pio, timer, sysid  

compiled and built successfully on Cyclone II.However run error  

Pausing Target processor : not responding  

Went through faq , but cud not solve the problem 

plz suggest soln
0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi, 

please try to provide more detailed description of what your doing. 

 

So let me assume that your JTAG-Adapter wasn't able to find your HW. 

Clcik on run and open your Run Configurations... 

Under NIOS II Hardware there should be your device listet, choose it and change to tab Target connection, there should now be your jatag adapter visible under Processors and Byte Stream Device, if not click on refrech connections. 

 

Good luck
0 Kudos
Highlighted
Valued Contributor III
3 Views

Sir  

i am trying Nios II Hello program on the said SOPC builder setup and using CycloneII device 

 

1.device not available in main tab 

2.Refreshed jtag cable and jtag device (EP2C35 ) in Target connection tab 

 

problem not solved:( 

plz help
0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi there, 

if there's no device recognized in the main tab, how did u come to refresh the connection? 

First create device: 

Go back to Run Configuration... 

Select Nios II Hardware 

Click on "New launch configuration" (the icon looks like a blank paper with a plus on it) 

Then you define a project name and choose your .elf while, which you build. 

After that it should run
0 Kudos
Highlighted
Valued Contributor III
3 Views

Sir, 

refresh connection available in the Target connection tab 

 

i think i hv selected whatever u said 

In Run Dialog box 

LHS i select NiosII Hardware, rt click, i get New/Duplicate/Delete 

click New , i get hello_world_small1_Nios II hw configuration 

 

RHS i get  

 

Main tab---- project:hello_world_small1 

NiosII elf : Release/hello_world_small1.elf 

ptf file : C:\altera\72sp3\quartus\rt\sysrt.ptf 

 

In Target Connection tab---- 

 

jtag cable: USB-Blaster 0 

jtag device: (EP2C35 )  

Nios II commn device:jtag_uart(stdin/stdout/stderr)
0 Kudos
Highlighted
Valued Contributor III
3 Views

Sir, 

 

problem was with pin assignment .csv file  

 

error resolved:)
0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi, 

glad to hear you fixed your problem. 

 

Could you provide a detailed description on how you fixed the error, so that other users facing similar problems could get some help here. 

 

Have a nice week end
0 Kudos
Highlighted
Valued Contributor III
3 Views

The names of the input and output pins in the .bdf file  

were matched with the .csv file pin names 

 

and compiled! 

Simple problem but took time to detect since i had used the software after 

a gap of about one year 

 

Regards ,
0 Kudos