Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12408 Discussions

Nios II Software Build Tools for Eclipse freezes from Java error

KEhle3
Beginner
685 Views

I'm using Nios II Software Build Tools for Eclipse (Eclipse IDE for C/C++ Developers, Mars.2 Release (4.5.2), Build id: 20160218-0600) as part of Quartus Prime (Version 18.0.0, Build 614 04/24/2018 SJ Standard Edition).

 

Occasionally, the Nios II Eclipse IDE will just freeze, sometimes even when sitting idle. An Eclipse pop-up appears showing that a Java error occurred (see Nios_II_Software_Build_Tools_for_Eclipse_Java_error.png attachment). Is this a known issue? Is there a fix for it?

0 Kudos
3 Replies
Ahmed_H_Intel1
Employee
305 Views

Hi,

Can you check the following if this will solve your problem?

Check the workaround available here and let me know if this solves the issue.

https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/tools/...

Regards,

KEhle3
Beginner
305 Views

This workaround is for Platform Designer; however, my issue is with Nios II Software Build Tools for Eclipse. Additionally, this workaround is for Quartus Prime version 17.1 update 2 and earlier; however, I'm using Quartus Prime version 18.0.0. The Java error looks very different, but I looked into the workaround/fix anyway. No (good) luck. Anything else seem like a possible fit?

Ahmed_H_Intel1
Employee
305 Views

Have you tried another version of Quartus?

 

 

Reply