Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12455 Discussions

Nios II not responding in POF mode for some commands

Altera_Forum
Honored Contributor II
850 Views

Hello  

 

In our system we have connected two ICs over SPI bus to NIOS II processor and USB to FIFO connected to PIO core for communication with HOST system.  

We have developed firmware which receives commands over USB – FIFO and writes data into the ICs connected over SPI bus. 

 

We have tested the firmware in run mode and debug mode and everything works fine. We do not see any issue in these modes. 

We don’t have external flash memory, so we are fusing the firmware with POF by converting elf file to hex file and compile it to produce POF file.  

On power up FPGA gets configured with the POF from configuration device and initially firmware works fine. 

 

But at some point of time firmware stops responding which was not happening when we run in run mode or debug mode. 

 

Can someone please give suggestions for this problem. We are using Quartus 14.0 Version.  

 

Thank you
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
159 Views

Check the exception and interrupt vectors. I had a similar problem and it turned out that they weren't being initialized when the code was in a pof file but they were when loaded directly. Of course this might not have anything to do with your issue.

Reply