Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12435 Discussions

No CFI Table Found at Base 0x0

Altera_Forum
Honored Contributor II
761 Views

Hi, 

 

I have a Nios II system with CFI controller (Generic Tri-state controller) at base 0x0 in Qsys. What I've done is to program the CFI flash memory with my Nios II system (hardware image converted from sof2flash with --optionbit, --pfl and .etc) using nios2-flash-programmer tool. 

 

After that, I have also program my PFL design into my MAX V device in such a way that upon power cycling my board, the hardware image will be loaded by PFL and configure the FPGA. 

 

Although FPGA is successfully configured upon next power cycle as seen from the LED turning green, my problem is that the CFI flash is somehow NOT seen. When I simply tried "nios2-flash-programmer -b 0x0 --debug", it says that NO CFI TABLE FOUND AT 0x0. But if I tried running a simple hello world program in Nios II SBT Eclipse, Hello World was able to be run. What could lead to this failure? The PFL that burnt into the MAX V or my Nios II system design?  

 

Thanks, 

-carid
0 Kudos
0 Replies
Reply