Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
753 Views

No Ethernet with nios2 mmu stdandard design

Hello, 

I'm currently trying to build my own custom FPGA design. I'm using the Nios2 nios2_linux_3c120_125mhz example from Altera Wiki and also the design from Altera website nios2 mmu example design.  

(http://www.altera.com/support/examples/nios2/exm-mmu.html

 

When I power on my 3c120 devboard with uClinux distribution U-boot is launched. And you can try to ping your computer. Nevertheless, Ethernet is only working with the .sof nios2_linux_3c120_125mhz from Altera wiki (quartus 8.1). 

When I recompile this design under quartus 11.1 a top_time_limited.sof is generated, but when downloaded on the board Ethernet doesn't work because I can't ping my computer under U-boot. 

(TX LED is blinking on the Ethernet port but program display "Using tse0 device, ping failed host not alive..." ).  

 

I think the problem comes from the FPGA design or quartus version. Or maybe TSE component which is an opencore plus IP. 

Ethernet doesn't work also for the two design from Altera website qsys and sopcbuilder version. 

 

Please help ! :cry:
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
48 Views

Actually, Ethernet is working with uClinux but not working with u-boot: 

 

When the nios2_3c120_1258mhz_top.sof design is downloaded, U-boot start : 

U-Boot 2009.01 (Apr 25 2009 - 13:37:29) 

 

CPU : Nios-II 

SYSID : 0x45ff1c2a, Fri Jan 30 03:53:01 2009 

BOARD : Altera 3C120 

Net: board eth init 

Altera TSE init 

Marvell 88E1111S found 

tse0 

Hit any key to stop autoboot: 0  

==>  

With my custom_fpga.sof, U-boot start 

 

U-Boot 2009.01 (Apr 25 2009 - 13:37:29) 

 

CPU : Nios-II 

SYSID Net: board eth init 

Altera TSE init 

Marvell 88E1111S found 

tse0 

Hit any key to stop autoboot: 0  

==>  

 

Nothing after SYSID ? 

My SYSID in qsys is 0x0.  

Could it explain the fact that ping and dhcp don't work ?
Reply