Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
2,067 Views

No "Hello World" appears on the console.

I have the Arria V Starter Kit and the PCIe is fine but I need to add NIOS II to the design. 

 

I went to the BTS examples and bts_config that has a NIOS II , Internal Memory and a bunch of peripherals including  

the JTAG_UART. The clock is running at 50 Mhz and I load the .sof file. 

 

In Eclipse, I greate the project , build and run per the example tutorial. Everythinmg looks Ok except no "Hello World" on the console. 

There was some comments that if there was some communications setting , then a real UART is used and a terminal and cable required to see  

console messages. I checked in QSYS and the UART instantiated is the JTAG_UART which I believe must capture character output and have the  

characters received via JTAG and displayed on the Eclipse console . ( could it be that there is a dedicated Eclipse console or is it the regular console 

tab on the GUI where other messages appear ? ). 

 

I then tried to run in debug mode and stepping through code did look like a printf function call was being processed .. ie strlen to determine the string lenght then some character output routines . However still can't see any "Hello World" message. 

 

I figured I could add an "alive led" to make sure things are running but now thinking about it, it the debugged code was making progress then the NIOS II core has to be running to be executing the code in debug mode. 

 

Obviously some beginner problem ... but I need to get past "Hello World" and add the PCIe back in before I can move forward with the project at hand. 

 

Thanks in Advance. Bob 

 

PS: Do I need to use the Eclipse that came with the Starter Kit CD ? 

I have this one. 

Eclipse IDE for C/C++ Developers 

 

 

Version: Indigo Service Release 2 

 

Build id: 20120216-1857 

0 Kudos
5 Replies
Altera_Forum
Honored Contributor I
313 Views

Hi, you have succeeded in configuring your board with the right .sof. 

Have you succeeded in downloading the software (eclipse nios ii sbt> run as ...) ? No error messages like "verification failed between...."
Altera_Forum
Honored Contributor I
313 Views

 

--- Quote Start ---  

Hi, you have succeeded in configuring your board with the right .sof. 

Have you succeeded in downloading the software (eclipse nios ii sbt> run as ...) ? No error messages like "verification failed between...." 

--- Quote End ---  

 

 

Hi mmTsuchi, Hany thanks for the input. 

 

The .sof file I am loading has the date/time and name I would expect for the design I just compiled ( bts example ). So I believe it is the coffect .sof . 

 

On occasions I got , the "Run Configurations" dialog box appeared which is mentioned on page 1-7 of the "My First Nios II Software Tutorial". 

I clicked on Refresh then Run as indicated and the application is loaded and started. Then nothing on the console. 

 

As I previoulsy mentioned , I believe the Blaster and Jtag communication myst be working since in Debug mode, I am able to step through code in the Eclipse debugger and it certainly looks like code to output a string. 

 

This is why I suspect the JTAG_UART .. and there is mention of the possibility of the stdout being directed to a real UART but I don't see one in the design. 

 

I may try to flash a LED ... if that works then the problem is JTAG_UART related I believe. 

On Lauterbach they have "semihosting" which I believe may be a similar mechanism to the JTAG_UART . 

 

Best Regards, Bob. 

 

PS: I am surprised that with "Hello world" for the Arria V Starter Kit or any other kit, doesn't have a minimum FPGA design in the same spirit of "Hello world" being a minimum C program ie Nios II + Internal memory + JTAG_UART and an alive_led output . Such a minimum design may help first time users going since even the simple application here is non-trivial.
Altera_Forum
Honored Contributor I
313 Views

Got a "Hello world" out of the FPGA ... thanks for hints. 

 

I believe this was my issue. I copied the archived project from the sample directory to a work dir. 

The QUARTUS system re-established the design environment and somehow in programming the FPGA the  

device type had become unknown. 

 

I was able to pick this up when checking if the clk_50 input on the "Pin Planner" view didn't connect to the  

clkin_50_top or clkin_50_bot on the Starter card schematic. 

 

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=8326
Altera_Forum
Honored Contributor I
313 Views

Of course there are example softwares like "hello word" that work with altera board out-of-the-box : 

If Quartus + Nios II are completely installed , when you create a "hello word" from template in nios ii sbt (or ide), you could choose an altera factory qsys (or sopc)

 

To choose JTAG_UART as default UART (linked to stdin, stdout, (stderr)), enter in the Board Support Package (BSP) (or system_library if you are using Quartus < 10). But I remember that I ran "Hello word" without modifying anything : I have an Altera Nios II dev board (cyclone II FPGA) 

 

The "minimal designs" as you said are available in Quartus subdirectories (i am not sure now) or at www.altera.com see devboards (there are zip files) to find the .sof 

 

For me, I need to start NIOS II SBT (12.0sp1) twice to successfully download a software to my board. 

 

If you can't see nios2 console tab in Eclipse and you are not afraid with command line, you can open a windows shell and type something like "c:\altera\12.0sp1\nios2eds\bin\nios2-terminal.exe

I guess it is not a FIFOed UART that needs to be flushed in order to be passed through the wires. 

 

i don't know arria v starter kit. 

 

EDIT: 

Nice, you found ! 

 

 

--- Quote Start ---  

I copied the archived project [...]. The QUARTUS [...] and somehow in programming the FPGA the device type had become unknown

--- Quote End ---  

 

Did you copy the project with the "archive project" or "copy project" fonction of Quartus ? 

Which version of Quartus ?
Altera_Forum
Honored Contributor I
313 Views

Thanks mmTsuchi, 

 

1) I thought I copied the zipped folder and unzipped it and somehow lost the particular device being used. 

 

2) QARTUS level https://www.alteraforum.com/forum/attachment.php?attachmentid=8329  

 

Thanks, Bob
Reply