Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
770 Views

Permission denied (public key) when running ./update with git on Nios2 Linux

hi, I am using Centos 6.4 on 64 bits OS and I follow the instruction at http://www.alterawiki.com/wiki/install_nios_ii_linux, I got the following error when running [/home/hippo/nios2-linux]# ./update 

update binutils.. 

Already up-to-date. 

update gcc3.. 

Already up-to-date. 

update linux-2.6.. 

Already up-to-date. 

update toolchain-build.. 

Already up-to-date. 

update toolchain-mmu.. 

Already up-to-date. 

update uClibc.. 

Already up-to-date. 

update elf2flt.. 

Already up-to-date. 

update insight.. 

Already up-to-date. 

update u-boot.. 

Already up-to-date. 

update uClinux-dist.. 

Already up-to-date. 

update boards.. 

Already up-to-date. 

update openip.. 

Permission denied (publickey). 

fatal: The remote end hung up unexpectedly 

update tools.. 

Your configuration specifies to merge with the ref 'master' 

from the remote, but no such ref was fetched. 

 

May I know how can I get over this? Is it necessary for openip and tools to get update?
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
52 Views

 

--- Quote Start ---  

hi, I am using Centos 6.4 on 64 bits OS and I follow the instruction at http://www.alterawiki.com/wiki/install_nios_ii_linux, I got the following error when running [/home/hippo/nios2-linux]# ./update 

update binutils.. 

Already up-to-date. 

update gcc3.. 

Already up-to-date. 

update linux-2.6.. 

Already up-to-date. 

update toolchain-build.. 

Already up-to-date. 

update toolchain-mmu.. 

Already up-to-date. 

update uClibc.. 

Already up-to-date. 

update elf2flt.. 

Already up-to-date. 

update insight.. 

Already up-to-date. 

update u-boot.. 

Already up-to-date. 

update uClinux-dist.. 

Already up-to-date. 

update boards.. 

Already up-to-date. 

update openip.. 

Permission denied (publickey). 

fatal: The remote end hung up unexpectedly 

update tools.. 

Your configuration specifies to merge with the ref 'master' 

from the remote, but no such ref was fetched. 

 

May I know how can I get over this? Is it necessary for openip and tools to get update? 

--- Quote End ---  

 

 

Hi, I manage to resolve the issue by running git clone manually. git clone git://sopc.et.ntust.edu.tw/git/boards.git  

git clonegit://sopc.et.ntust.edu.tw/git/openip.git 

git clonegit://sopc.et.ntust.edu.tw/git/tools.git
Altera_Forum
Honored Contributor I
52 Views

I manage to resolve it by manually running inn terminal window: 

 

git clone git://sopc.et.ntust.edu.tw/git/boards.git 

git clone git://sopc.et.ntust.edu.tw/git/openip.git 

git clone git://sopc.et.ntust.edu.tw/git/tools.git
Reply