Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12500 Discussions

Please can we have some help on the WSL\NiosIi\Eclipse build problems following the windows update


I have Quartus 20.1 on Windows 10 and have today tried to rebuild a project using the NiosII eclipse platform.   The project was working fine a  few months ago and now I cannot get the eclipse tool chain to work, with eclipse reporting various file\folder\path not found errors, command not found errors,  and various unknown architecture errors that all seem to be associated with WSL path problems.  Likewise, if I create a new project it does not work. I can count numerous forum posts since September and all report problems which on first pass look to be different facets of the same problem.  The root cause seems to  be a windows  update which has broken the Quartus\NiosII\EDS\WSL  tool chain.

This is a serious issue, and having spent the day going through the below posts none seem to satisfactorily resolve the problems.  Please can Intel provide help on this.  Like many others, this has resulted in a dead stop in project development so I would certainly appreciate a timely resolution.

Thanks in Advance


For reference – the most comment suggestion from intel seems to be the below, but this does not work.

To workaround the problem, you can follow the steps below:

1) uninstall Ubuntu* 18.04 (if you have one)

2) uninstall wsl  

3) re-install wsl

4) download latest Ubuntu 18.04 from Microsoft Shop & install it

5) execute following on Ubuntu shell :  

   sudo apt-get update

   sudo apt install wsl 

   sudo apt install dos2unix

   sudo apt install make 

   sudo apt-get upgrade 

Post related to this seem to be:

0 Kudos
8 Replies

Hi @DavidCambridge,

Thank you for posting in Intel community forum and hope you are doing well.
Apologies for the inconvenient cause, yes the cause that we identified so far for now is due to the windows updates.
We are actively working with the development team to mitigate this with a permanent solution on the next software patched.
As for now for Quartus 20.1, for the time being there is a workaround in place by using the NIOS II command shell to build the system. There would be some error upon building the project, please refer to the steps below to attend to it:

- Open a NIOS2 command shell
- try and make an NIOS2 application
- You get the following error: nios2-elf-gcc.exe: error: CreateProcess: No such file or directory
- To resolve this you need run the following command prior to calling make, "export WSLENV=PATH/l:${WSLENV}"

- With the above fix you can compile all the files but the link fails: nios2-elf-g++.exe: error: missing argument to '-msys-lib='
- To resolve this you need to modify the application Makefile and change the following line:
      APP_LDFLAGS += -msys-lib=$(call adjust-path-mixed,$(SYS_LIB)) to APP_LDFLAGS += -msys-lib=$(SYS_LIB)
- In adjust-path-mixed should not be used in this case as SYS_LIB is a name of a library not a PATH to the library

- The final problem is that from eclipse debugging fails with the following error:
      wslpath: /mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec: No such file or directory
      wslpath: /mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec: No such file or directory
      Using cable "USB-BlasterII [USB-1]", device 1, instance 0x01
      Pausing target processor: OK
      Restarting target processor
      rm: cannot remove '/mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec': No such file or directory
- To resolve this problem the Application Makefile must be modified again with the following change:
      BUILD_PRE_PROCESS := to BUILD_PRE_PROCESS := touch $(ELF).srec

Please do let us know if you have any trouble completing the workaround above.

Warm regards.


I don't know that it will help but my Eclipse build template command started working after I noticed the last line of text above the prompt after running the command "sudo apt update" in the Ubuntu command shell, the first of 4 command lines found in the "Intel FPGA Software Installation and Licensing" guide section 2.3.1.  The text referred to items that needed to be "Upgraded"  The command "sudo apt upgrade" worked for me.  I then re-ran the remaining three command lines and looked for anything else that needed to be upgraded.  There were none.  After that I was suddenly able to create Eclipse project templates, but I had tried everything else I could find before that point and the process woudl fail with the error message failed to execute dos2unix.

Hope it helps you.


Hi @DavidCambridge,

By any chances did you managed to look into the workaround mention?

Please do let us know if you have any issues completing those steps and we would be more than happy to look into it.


Warm regards


Hi @DavidCambridge,

Hope this message find you well and good day, as we do not receive any response from you to the previous clarification that we have provided. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 
Warm Regards



I was not able to get the procedure you describe to work. I did however find the below post which gives a link to a patch.

Unfortunately, when I try and apply the patch I get an error messages to tell me that the patch is for version  but I have version  I then visited the quartus down load page to see if there was a later version, but I struggled to download using this account. When I tried I was locked in an endless loop between the download page and the account login page.  To solve this I had to create  a new account, but then I discovered the latest version us ?





I should add to the above that if you apply the patch anyway, and regardless of the version mismatch, it doesn't work and the build problems still exist.


Hi @DavidCambridge,

Sorry to hear that and apologies for the inconvenient, to double check the above workaround to use the NIOS2 command shell does not work for you to build the design?
Also the patched that you mention you have tried is it in the following KDB? And that is also not working?
Possible to share what are the quartus version that you have tried those step and the error message that you are seeing?
You are using WSL 1 yes?

Warm regards.


Thanks again for the response. Regarding your questions:

‘to double check the above workaround to use the NIOS2 command shell does not work for you to build the design?’  Yes, that is correct the workarounds do not work. After making the suggested changes, I now get the error message “nios2-elf-g++.exe: error: missing argument to '-msys-crt0='”

‘Also the patched that you mention you have tried is it in the following KDB? And that is also not working?’  Yes, that is correct. I find after applying the patch I can’t generate the BSP. It fails with an unable to execute wsl dos2unix error.

‘Possible to share what are the quartus version that you have tried those step and the error message that you are seeing?’ . Please refer to me post above. I have described the quartus version numbers, the installation error messages, and I refer you to the above comment where I note after installing the patch it breaks being able to generate the BSP.

‘You are using WSL 1 yes?’  - at the moment I’m on version 1, I’ve also tried 2, but that also failed.

I do appreciate the help I’m getting here, but I think it’s also fair to point out that it’s almost a month since I raised this post and longer since others pointed out the same problem - hence I’d really appreciate it if we can get this fixed.  

Thanks in advance