Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
747 Views

Problem building hello_world

Hey anyone 

I have this problem. 

I have bought a cyclone dev. kit. and used the standard niosII_cyclone_1c20 form the example list in Quartus. 

this kan be compiled with no error. 

But when i try to build my hello_world in nios this error come(look below) 

 

Anyone knows what I am doing wrong. 

 

Best regards  

Imagine 

 

**** Incremental build of configuration Debug for project hello_world_0 **** 

 

make -s all  

Creating generated_app.mk... 

Can't locate sh_launch.pm in @INC (@INC contains: /cygdrive/c/altera/kits/nios2_51/bin:/cygdrive/c/altera/quartus51/sopc_builder/bin::/cygdrive/c/altera/quartus51/sopc_builder/bin:/cygdrive/c/altera/quartus51/sopc_builder/bin/europa:/cygdrive/c/altera/quartus51/sopc_builder/bin/perl_lib .) at - line 3. 

BEGIN failed--compilation aborted at - line 3. 

make: *** [C:/altera/kits/nios2_51/examples/verilog/niosII_cyclone_1c20/standard/software/hello_world_0_syslib_0/Debug/system_description/../obj/generated_app.mk-t] Error 2 

Build completed
0 Kudos
2 Replies
Valued Contributor III
5 Views

Hmm, in my NIOS 5.1 installation sh_launch.pm exists in the altera\kits\nios2_51\bin directory so the script should find it. Check to see if you have that file. Also check the case, I think it might be case sensitive. 

 

The existing project probably works because it doesn't have to run generated_app.mk. This only happens when your NIOS design changes. 

 

Andrew
0 Kudos
Highlighted
Valued Contributor III
5 Views

The problem is not there anymore. 

I have reinstalled Quartus and Nios. 

 

Maybee not the smartest way but now it works again.  

I think the problem began when i changede my perl file, to a newer on. 

 

Thanks for you quick reply Queisser. 

 

/Imagine
0 Kudos