Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
735 Views

Problem while doing SoCkit_SW_13.0 lab

I've downloaded the 'SoCKIT_Materials.zip' and do the involved labs: SoC_HW_Lab_13.0 and SoC_SW_Lab_13.0. I had problems when debugging the preloader in the SW lab: 

 

when start debugging(click the debug button in DS-5), it first goto the reset instruction of the start.S file: 

 

reset: 

bl save_boot_params 

 

, then jump to the save_boot_params function of the lowlevel_init.S file: 

 

/* Save the parameter pass in by previous boot loader */ 

.global save_boot_params 

save_boot_params: 

# ifdef CONFIG_SPL_BUILD# if (CONFIG_PRELOADER_DEBUG_MEMORY_WRITE == 1) 

/* 

* write the debug memory header and value of R0 - R3 (which passed 

* by BootROM) into debug memory region (which is on ocram) 

*/ 

ldr r5, =CONFIG_PRELOADER_DEBUG_MEMORY_ADDR 

ldr r4, =PRELOADER_DEBUG_MEMMORY_HEADER 

stmia r5!, {r4} 

stmia r5, {r0 -r3} 

/* get the reset manager status register passed by BootROM */ 

add r5, r0,#0x34 

ldr r4, =rst_mgr_status 

ldr r5, [r5] 

str r5, [r4]# endif /* CONFIG_PRELOADER_DEBUG_MEMORY_WRITE */ 

 

My first debug always halted at the 'ldr r5, [r5]' instruction. Then click the reset button(back to entry point) to do re-debug, and it can work correctly. 

 

Any one knows why? 

BTW, my quartus is version 13.1, and DS-5 is 5.15.0.
0 Kudos
1 Reply
Highlighted
Honored Contributor I
23 Views

The problem has been solved. I found a new lab material for quartus 13.1: 

http://www.rocketboards.org/pub/documentation/arrowsockitevaluationboard/sockit_materials_13.1.zip
0 Kudos