Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,766 Views

Problems with Eclipse Build Tools and Model Sim

I am at the point where I am beginning to test some of the code I have written in the Eclipse GUI. I am trying to simulate this code on an RTL level using Model Sim. When I select Nios II model sim on the run tab, I receive a pop-up window with the following error attached.  

 

http://www.alteraforum.com/forum/attachment.php?attachmentid=10645&stc=1  

 

I am running the web edition of Quartus. Is this the issue? Does anyone have any ideas?
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
124 Views

Actually it's hard to see the screen shot. Pls put the the error message in text.

Altera_Forum
Honored Contributor I
124 Views

 

--- Quote Start ---  

Actually it's hard to see the screen shot. Pls put the the error message in text. 

--- Quote End ---  

 

 

Failed Executing: make sim SPD=C:/altera/14.1/sel2740x_hmi_ctrl_sys/nios_tb.spd ELF=C:/altera/14.1/sel2740x_hmi_ctrl_sys/software/nios_prog/nios_prog.elf ENABLE_VSIM_GUI=1 VSIM_DIR='C:/altera/14.1/modelsim_ase/win32aloem' return code: 2
Altera_Forum
Honored Contributor I
124 Views

 

--- Quote Start ---  

Actually it's hard to see the screen shot. Pls put the the error message in text. 

--- Quote End ---  

 

 

In the console I am left with this error. Do I not have the correct/valid license for modelsim?
Altera_Forum
Honored Contributor I
124 Views

Well, I managed to find the issue. Apparently when launching ModelSim from Eclipse, the tools are automatically looking for the subscription edition of ModelSim. If you have the Quartus web edition, or subscription edition without a ModelSim license, you will get this error. 

 

Altera released a patch that will fix this issue. Please see this link if you are having troubles. http://www.alteraforum.com/forum/showthread.php?t=46242
Reply