Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12455 Discussions

Qsys Pro Software Builder (.sopcinfo does not contain any CPU)

Altera_Forum
Honored Contributor II
1,863 Views

Okay, I'm obviously missing something important. 

 

I'm using Quartus Prime Pro for Arria 10. If I build a system in Qsys (non-Pro), everything seems to work fine. I can take the system through the Software Build Tools and simulation, no problem. 

 

However, if I take the identical project through Qsys Pro, again *mostly* everything seems to work fine. 

 

When I get to the Software Build Tools, I point to the .sopcinfo file and the tools tell me that ".sopcinfo does not contain any CPU". I can see the CPU information in the .sopcinfo file using a text editor. 

 

I suspect that the file format has changed and that there's a new way to build a simulation design for Qsys Pro. Unfortunately, Uncle Google couldn't seem to find it either. 

 

Does anybody have a pointer on how to make this happen? Thanks in advance for any pointers. 

 

Quartus Prime Pro: 16.0.2 Build 222 07/26/2016 SJ Pro Edition 

Qsys Pro (Beta) 16.0.2 Build 222 

Eclipse: Kepler Service Release 2, Build id: 20140224-0627 

Windows 10 Home
0 Kudos
5 Replies
Altera_Forum
Honored Contributor II
528 Views

Are you using the software build tools from the Pro edition of Quartus? The Non-Pro software tools probably won't generate a system for the Arria 10. If you are using the Pro software tools, it looks like you found a bug in Qsys Pro (Beta). This needs to be reported to Altera.

Altera_Forum
Honored Contributor II
528 Views

 

--- Quote Start ---  

Are you using the software build tools from the Pro edition of Quartus? The Non-Pro software tools probably won't generate a system for the Arria 10. If you are using the Pro software tools, it looks like you found a bug in Qsys Pro (Beta). This needs to be reported to Altera. 

--- Quote End ---  

 

 

Yep, it's all Quartus Prime Pro, Qsys Pro (beta). I have an SR on file on the topic. I'll update the forum with what we find.
Altera_Forum
Honored Contributor II
527 Views

Did you click on "Sync All System Info" and regenerate your design again?

TKhan7
Beginner
528 Views

Was this issue resolved yet? since I am having the same problem now.

SHauk2
Beginner
528 Views

I received the same message while creating a new project. It however, disappeared and was replace with "Project name is empty" within 10 minutes while I was googling the error message. Apparently it was still in the process of parsing the sopcinfo file.

Reply